This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1469786 - NetworkManager misconfigures resolv.conf search parameter
NetworkManager misconfigures resolv.conf search parameter
Status: CLOSED DUPLICATE of bug 1470966
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 16:25 EDT by Werner Gold
Modified: 2017-07-20 03:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 03:08:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Werner Gold 2017-07-11 16:25:57 EDT
Description of problem:

NetworkManager adds the hostname to the domain in the search parameter instead of just using the domain name.

Version-Release number of selected component (if applicable):
NetworkManager-1.8.0-6.fc26.x86_64
dhcp-client-4.3.5-7.fc26.x86_64

How reproducible:

Each time.

Steps to Reproduce:
1. Start a dynamic interface (DHCP)


Actual results:

In /etc/resolv.conf:
search freder.intgold

Expected results:

/etc/resolv.conf:
search intgold


Additional info:
DHCP Server:
option domain-name "intgold";

Journal on freder:
NetworkManager[19960]: <info>  [1499804584.7162] dhcp4 (wlp4s0):   domain name 'intgold'

Behavior was different on F25
Comment 1 Peter Larsen 2017-07-11 16:46:22 EDT
Werner can you elaborate on how you configured NMCLI to do this? Adding a dns-search string to a static (my only available interface right now) just inserts that text into the /etc/resolv.conf search option exactly as written. There's no hostname etc. added.
Comment 2 Werner Gold 2017-07-11 17:07:59 EDT
[root@hiphop ~]# nmcli connection show goldinoch 
connection.id:                          goldinoch
connection.uuid:                        00102352-d79f-4a21-9bed-dac5142b1a91
connection.stable-id:                   --
connection.interface-name:              --
connection.type:                        802-11-wireless
connection.automatisches Verbinden:     yes
connection.autoconnect-priority:        0
connection.autoconnect-retries:         -1 (Vorgabe)
connection.timestamp:                   1499807026
connection.read-only:                   no
connection.permissions:                 --
connection.zone:                        --
connection.Master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (Vorgabe)
connection.secondaries:                 --
connection.gateway-ping-timeout:        0
connection.metered:                     unbekannt
connection.lldp:                        -1 (default)
802-11-wireless.ssid:                   goldinoch
802-11-wireless.mode:                   infrastructure
802-11-wireless.band:                   --
802-11-wireless.channel:                0
802-11-wireless.bssid:                  --
802-11-wireless.rate:                   0
802-11-wireless.tx-power:               0
802-11-wireless.mac-address:            84:3A:4B:00:55:40
802-11-wireless.cloned-mac-address:     --
802-11-wireless.generate-mac-address-mask:--
802-11-wireless.mac-address-blacklist:  --
802-11-wireless.mac-address-randomization:Vorgabe
802-11-wireless.mtu:                    auto
802-11-wireless.seen-bssids:            C0:C1:C0:D1:EC:C0,00:0B:6B:2E:76:4B,F8:32:E4:A8:CA:68
802-11-wireless.hidden:                 no
802-11-wireless.powersave:              default (0)
802-11-wireless-security.key-mgmt:      wpa-psk
802-11-wireless-security.wep-tx-keyidx: 0
802-11-wireless-security.auth-alg:      open
802-11-wireless-security.proto:         --
802-11-wireless-security.pairwise:      --
802-11-wireless-security.group:         --
802-11-wireless-security.leap-username: --
802-11-wireless-security.wep-key0:      <verborgen>
802-11-wireless-security.wep-key1:      <verborgen>
802-11-wireless-security.wep-key2:      <verborgen>
802-11-wireless-security.wep-key3:      <verborgen>
802-11-wireless-security.wep-key-flags: 0 (keine)
802-11-wireless-security.wep-key-type:  0 (unbekannt)
802-11-wireless-security.psk:           <verborgen>
802-11-wireless-security.psk-flags:     0 (keine)
802-11-wireless-security.leap-password: <verborgen>
802-11-wireless-security.leap-password-flags:0 (keine)
ipv4.method:                            auto
ipv4.dns:                               --
ipv4.dns-search:                        intgold
ipv4.dns-options:                       (Vorgabe)
ipv4.dns-priority:                      0
ipv4.addresses:                         --
ipv4.gateway:                           --
ipv4.routes:                            --
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv4.dad-timeout:                       -1 (Vorgabe)
ipv6.method:                            auto
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       (Vorgabe)
ipv6.dns-priority:                      0
ipv6.addresses:                         --
ipv6.gateway:                           --
ipv6.routes:                            --
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unbekannt)
ipv6.addr-gen-mode:                     eui64
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
ipv6.token:                             --
proxy.method:                           none
proxy.browser-only:                     no
proxy.pac-url:                          --
proxy.pac-script:                       --
GENERAL.NAME:                           goldinoch
GENERAL.UUID:                           00102352-d79f-4a21-9bed-dac5142b1a91
GENERAL.GERÄTE:                         wlp3s0
GENERAL.STATUS:                         aktiviert
GENERAL.VORGABE:                        ja
GENERAL.STANDARD6:                      nein
GENERAL.VPN:                            nein
GENERAL.ZONE:                           --
GENERAL.DBUS-PFAD:                      /org/freedesktop/NetworkManager/ActiveConnection/2
GENERAL.CON-PFAD:                       /org/freedesktop/NetworkManager/Settings/3
GENERAL.SPEC-OBJECT:                    /org/freedesktop/NetworkManager/AccessPoint/37
GENERAL.MASTER-PFAD:                    --
IP4.ADRESSE[1]:                         192.168.99.115/24
IP4.GATEWAY:                            192.168.99.222
IP4.DNS[1]:                             192.168.99.253
IP4.DOMAIN[1]:                          intgold
DHCP4.OPTION[1]:                        requested_routers = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_classless_static_routes = 1
DHCP4.OPTION[7]:                        host_name = hiphop
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        requested_broadcast_address = 1
DHCP4.OPTION[10]:                       next_server = 0.0.0.0
DHCP4.OPTION[11]:                       expiry = 1499813026
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       requested_subnet_mask = 1
DHCP4.OPTION[14]:                       routers = 192.168.99.222
DHCP4.OPTION[15]:                       dhcp_message_type = 5
DHCP4.OPTION[16]:                       ip_address = 192.168.99.115
DHCP4.OPTION[17]:                       requested_static_routes = 1
DHCP4.OPTION[18]:                       domain_name = intgold
DHCP4.OPTION[19]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[20]:                       requested_domain_name_servers = 1
DHCP4.OPTION[21]:                       requested_nis_servers = 1
DHCP4.OPTION[22]:                       requested_ntp_servers = 1
DHCP4.OPTION[23]:                       domain_name_servers = 192.168.99.253
DHCP4.OPTION[24]:                       dhcp_lease_time = 6000
DHCP4.OPTION[25]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[26]:                       broadcast_address = 192.168.99.255
DHCP4.OPTION[27]:                       requested_nis_domain = 1
DHCP4.OPTION[28]:                       network_number = 192.168.99.0
DHCP4.OPTION[29]:                       requested_host_name = 1
DHCP4.OPTION[30]:                       dhcp_server_identifier = 192.168.99.253
IP6.ADRESSE[1]:                         fe80::863a:4bff:fe00:5540/64
IP6.GATEWAY:                            --
Comment 3 Werner Gold 2017-07-11 17:31:32 EDT
As you can see from the output nmcli reports the correct search parameter, but still - on the machine "hiphop" - /etc/resolv.conf says:
search hiphop.intgold.

That applies to a totally standard dynamic interface without any special configuration.
Comment 4 Miroslav Lichvar 2017-07-12 15:39:08 EDT
In my case, after upgrading to F26 resolv.conf generated by NetworkManager no longer contains any search line. The domain name is provided by DHCP server.

The following Debian bug report seems to describe the issue with more details:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867909
Comment 5 Werner Gold 2017-07-13 06:03:34 EDT
I can't see how the Debian bug report is helpful to me.
I tried adding a /etc/NetworkManager/conf.d/dhcp.conf, but I still get the search domain with the hostname in it.
Comment 6 Beniamino Galvani 2017-07-20 03:08:40 EDT

*** This bug has been marked as a duplicate of bug 1470966 ***

Note You need to log in before you can comment on or make changes to this bug.