Bug 1469822 - Nothing obsoletes strigi-libs (installed by default in Fedora 24 KDE)
Nothing obsoletes strigi-libs (installed by default in Fedora 24 KDE)
Status: CLOSED DUPLICATE of bug 1498850
Product: Fedora
Classification: Fedora
Component: LiveCD - KDE (Show other bugs)
27
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sebastian Vahl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 18:06 EDT by Adam Williamson
Modified: 2017-10-22 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-22 09:14:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-07-11 18:06:15 EDT
A default Fedora 24 KDE install includes strigi-libs - not sure why, but probably one of these deps:

[adamw@adam fedora-comps (master)]$ sudo dnf repoquery --releasever 24 --whatrequires strigi-libs
Last metadata expiration check: 0:00:00 ago on Tue 11 Jul 2017 03:02:56 PM PDT.
kdegraphics-mobipocket-0:16.04.1-1.fc24.x86_64
kdegraphics-mobipocket-0:16.08.3-1.fc24.x86_64
kdegraphics-strigi-analyzer-0:16.04.1-1.fc24.x86_64
kdegraphics-strigi-analyzer-0:16.04.2-1.fc24.x86_64
kdelibs-6:4.14.20-1.fc24.i686
kdelibs-6:4.14.20-1.fc24.x86_64
kdelibs-6:4.14.30-2.fc24.i686
kdelibs-6:4.14.30-2.fc24.x86_64
kdenetwork-strigi-analyzers-7:16.04.1-1.fc24.x86_64
kdenetwork-strigi-analyzers-7:16.04.2-1.fc24.x86_64
kdesdk-strigi-analyzers-0:16.04.1-1.fc24.x86_64
kdesdk-strigi-analyzers-0:16.04.2-1.fc24.x86_64
strigi-0:0.7.8-12.fc24.x86_64
strigi-devel-0:0.7.8-12.fc24.i686
strigi-devel-0:0.7.8-12.fc24.x86_64

strigi was orphaned and retired last July, and now when you try and upgrade from F24 to Rawhide without --allowerasing , it fails because strigi-libs' dependencies are no longer satisfied (libexiv2.so.14).

--allowerasing will work around this, but it can be dangerous (can allow DNF to remove other packages that the user doesn't *want* to remove) and I believe retired packages should be properly obsoleted.

I'd suggest this could be obsoleted by, say, plasma-workspace, or some baloo package that will always be included in KDE, or if all else fails, by fedora-obsolete-packages.
Comment 1 Kevin Kofler 2017-07-11 18:47:59 EDT
I think kdelibs can obsolete it, it is what was dragging in strigi-libs to begin with and is now being built without Strigi.
Comment 2 Jan Kurik 2017-08-15 04:09:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 3 Rex Dieter 2017-10-22 09:14:24 EDT

*** This bug has been marked as a duplicate of bug 1498850 ***

Note You need to log in before you can comment on or make changes to this bug.