Bug 146987 - find /etc | xargs grep LANG causes Kernel Panic
find /etc | xargs grep LANG causes Kernel Panic
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 07:58 EST by Anderson
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 13:50:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'lspci' output (3.49 KB, text/plain)
2005-02-03 08:00 EST, Anderson
no flags Details
'lsmod' output (2.03 KB, text/plain)
2005-02-03 08:01 EST, Anderson
no flags Details
Syslog messages I've gotten when I ran the command (7.13 KB, text/plain)
2005-02-03 21:16 EST, Anderson
no flags Details
Syslog messages I've gotten when I ran the command under the kernel I built (7.13 KB, text/plain)
2005-02-03 21:17 EST, Anderson
no flags Details

  None (edit)
Description Anderson 2005-02-03 07:58:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
I get a Kernel Panic when I execute this command:

$ find /etc | xargs grep LANG

I can get the panic without root provileges.

When I run that command, it looks for files under /etc, but when it reaches /etc/udev/devices, these errors appears:

grep: /etc/udev/devices/nvidia0: Invalid argument
Kernel Panic - not syncing| arch/i386/kernel/semaphore.c: 64: spin_is_locked on unintialized spinlock f1b75fa8

I also could reproduce the bug using kernel 2.6.10-1.753_FC3 and 2.6.10-1.737_FC3. The kernel panic message changed a bit:

2.6.10-1.753_FC3:

grep: /etc/udev/devices/nvidia0: Invalid argument
Kernel Panic - not syncing| arch/i386/kernel/semaphore.c: 64: spin_is_locked on unintialized spinlock f1ab8fa8


2.6.10-1.737_FC3:

grep: /etc/udev/devices/nvidia0: Invalid argument
Kernel Panic - not syncing| arch/i386/kernel/semaphore.c: 64: spin_is_locked on unintialized spinlock f1abeea8


Version-Release number of selected component (if applicable):
2.6.10-1.760_FC3

How reproducible:
Always

Steps to Reproduce:
1. Open konsole
2. Type (without quotes) "find /etc | xargs grep LANG"
3. Press ENTER
    

Actual Results:  I've got a Kernel Panic

Expected Results:  The command should return all files under /etc that contain the text 'LANG'.

Additional info:
Comment 1 Anderson 2005-02-03 08:00:17 EST
Created attachment 110591 [details]
'lspci' output
Comment 2 Anderson 2005-02-03 08:01:06 EST
Created attachment 110592 [details]
'lsmod' output
Comment 3 Anderson 2005-02-03 08:01:52 EST
[root@anderson up2date]# nvidia-installer -i 
 
Welcome to the NVIDIA Software Installer for Unix/Linux 
 
 
The currently installed driver is: 'NVIDIA Accelerated Graphics 
Driver for Linux-x86' (version: 1.0-6629). 
 
Comment 4 Dave Jones 2005-02-03 13:50:59 EST
This looks like /etc/udev/devices/nvidia0 is world readable, and grep
tried to open it, resulting in a crash.

Comment 5 Anderson 2005-02-03 21:14:16 EST
That is! You are sure...

But I need to leave /etc/udev/devices/nvidia0 readable and writeable
for all users that belong to the 'users' group. Otherwise, only root
can use Xorg (and play my favorite games).

When I saw this bug closed, I decided to compile kernel 2.6.10 from
www.kernel.org. After booting the kernel I built, I repeated the
command and didn't get a kernel panic, but only a SEGV signal (a
kernel error in syslog, too). So, I still think there is a bug in
RedHat kernels, maybe a configuration problem or a patch.

I won't reopen this bug. But I want leave here that information.
Comment 6 Anderson 2005-02-03 21:16:42 EST
Created attachment 110635 [details]
Syslog messages I've gotten when I ran the command
Comment 7 Anderson 2005-02-03 21:17:20 EST
Created attachment 110636 [details]
Syslog messages I've gotten when I ran the command under the kernel I built
Comment 8 Dave Jones 2005-02-03 21:36:08 EST
in both cases, the panic happened inside the nvidia module. nothing we
can do to fix this.

Note You need to log in before you can comment on or make changes to this bug.