Bug 1469885 - RHV should not require optional channel (mod_session package) [NEEDINFO]
RHV should not require optional channel (mod_session package)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: releng (Show other bugs)
2.1.0
Unspecified Unspecified
high Severity high
: ovirt-4.1.5
: ---
Assigned To: Aviv Sabadra
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 23:38 EDT by Mark Keir
Modified: 2017-09-03 07:41 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-03 07:41:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Rel-Eng
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
asabadra: needinfo? (mkalinin)
mperina: needinfo? (rhodain)


Attachments (Terms of Use)

  None (edit)
Description Mark Keir 2017-07-11 23:38:14 EDT
Description of problem:
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/html-single/administration_guide/#Configuring_LDAP_and_Kerberos_for_Single_Sign-on documents the installation of mod_session for SSO, but the repository required, rhel-7-server-optional-rpms, is not mentioned in the installation guide in https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/html-single/installation_guide/#Subscribing_to_the_Red_Hat_Enterprise_Virtualization_Manager_Channels_using_Subscription_Manager

Version-Release number of selected component (if applicable):
4.0

How reproducible:
Always

Steps to Reproduce:
1. Follow installation guide
2. yum install mod_session (fail not found)
3.

Actual results:


Expected results:
[root@rhvm4 ~]# yum info mod_session
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
Installed Packages
Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 45.el7_3.4
Size        : 104 k
Repo        : installed
From repo   : rhel-7-server-optional-rpms
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.


Additional info:

The full list of required repositories is:
- rhel-7-server-rpms
- rhel-7-server-supplementary-rpms
- rhel-7-server-rhv-4.0-rpms
- jb-eap-7-for-rhel-7-server-rpms
- rhel-7-server-optional-rpms
Comment 7 Yaniv Kaul 2017-08-16 07:47:55 EDT
Eyal - who owns this package?
Comment 8 Eyal Edri 2017-08-16 09:09:14 EDT
mod_session? 
I don't know, never seen it as part of our releases.
It might be a dependency of another package, infra related maybe (LDAP),but I would expect it to come from the JBOSS channel. 
Adding Martin.
Comment 9 Martin Perina 2017-08-16 09:49:17 EDT
We don't have any direct RPM dependency on mod_session, but as mentioned above we need it along mod_auth_gssapi to provide Kerberos SSO feature since RHV 4.0 (on RHV 3.x we have use mod_auth_kerb, which is deprecated in EL7).

What I don't understand is the optional channel, because mod_session RPM is part of httpd package (same as for example httpd itself or mod_ssl) and AFAIK it's included in the base channel:

yum --show-duplicates info mod_session
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Available Packages
Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 64.el7
Size        : 57 k
Repo        : rhel-7-workstation-htb-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7
Size        : 57 k
Repo        : rhel-7-workstation-htb-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7
Size        : 57 k
Repo        : rhel-7-workstation-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7_4.2
Size        : 58 k
Repo        : rhel-7-workstation-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.


Aviv, am I right or missing something and mod_session is really not it base channel?
Comment 11 Aviv Sabadra 2017-08-16 11:10:23 EDT
Moving this to ON_QA so QE can verify nothing else is broken.

Do we need a knowledge base for customers with rhel 7.3? (Marina?)
Comment 12 Martin Perina 2017-08-18 06:36:59 EDT
(In reply to Aviv Sabadra from comment #11)
> Moving this to ON_QA so QE can verify nothing else is broken.
> 
> Do we need a knowledge base for customers with rhel 7.3? (Marina?)

Adding also Roman
Comment 13 Pavol Brilla 2017-08-21 08:23:33 EDT
7.4 server platform repositories contains mod_session 

# yum --show-duplicates info mod_session

Available Packages
Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 64.el7
Size        : 57 k
Repo        : rhel-7-server-htb-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7
Size        : 57 k
Repo        : rhel-7-server-htb-rpms/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7
Size        : 57 k
Repo        : rhel-7-server-rpms/7Server/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.

Name        : mod_session
Arch        : x86_64
Version     : 2.4.6
Release     : 67.el7_4.2
Size        : 58 k
Repo        : rhel-7-server-rpms/7Server/x86_64
Summary     : Session interface for the Apache HTTP Server
URL         : http://httpd.apache.org/
License     : ASL 2.0
Description : The mod_session module and associated backends provide an abstract
            : interface for storing and accessing per-user session data.
Comment 14 Eyal Edri 2017-09-03 07:41:05 EDT
fixed with RHEL 7.4 and 4.1.5.

Note You need to log in before you can comment on or make changes to this bug.