Bug 1469966 - Web Console button does not react according Cockpit availability
Web Console button does not react according Cockpit availability
Status: CLOSED DUPLICATE of bug 1497684
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Brian McLaughlin
Niyaz Akhtar Ansari
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2017-07-12 03:40 EDT by Jiri Stefanisin
Modified: 2018-02-02 06:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-11-16 08:02:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jiri Stefanisin 2017-07-12 03:40:39 EDT
Description of problem:
Even if VM does not have Cockpit running, it is possible to select Web Console option which leads to popup window with ERR_ADDRESS_UNREACHABLE.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Try to access Web Console on any VM without Cockpit

Actual results:

Expected results:
Button should be disabled or not shown at all if Cockpit site is unreachable.

Additional info:
Comment 3 Brian McLaughlin 2017-11-07 13:57:06 EST
Comment 4 Satoe Imaishi 2017-11-13 20:20:45 EST

*** This bug has been marked as a duplicate of bug 1497684 ***
Comment 5 Vatsal Parekh 2017-11-15 04:47:40 EST
(In reply to Satoe Imaishi from comment #4)
> *** This bug has been marked as a duplicate of bug 1497684 ***

The [BZ](https://bugzilla.redhat.com/show_bug.cgi?id=1497684) you marked duplicate of is different. This BZ is about if cockpit is running on the VM or not, and the marked duplicate BZ is about server role of cockpit.
Comment 6 Brian McLaughlin 2017-11-15 14:56:13 EST
Vatsal, we cannot detect if Cockpit is running on a given VM.  The resolution of this BZ is being handled by checking if the Cockpit role is enabled by the administrator signaling the availability of Cockpit on VMs.  The Web Console button will be reacting to the Cockpit console's availability in this way.
Comment 7 Vatsal Parekh 2017-11-16 00:57:36 EST
Brain, this BZ should be closed then, the Server Role BZ is different from description of this one.
Comment 8 Brian McLaughlin 2017-11-16 08:02:34 EST
I'm closing this as a duplicate as Satoe did previously, for the sole reason that while the title/description of the BZs do not match, the intent and end result of the BZs do.

*** This bug has been marked as a duplicate of bug 1497684 ***

Note You need to log in before you can comment on or make changes to this bug.