Bug 147002 - usbserial not part of default udev configuration
Summary: usbserial not part of default udev configuration
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-03 16:25 UTC by Jim Kingdon
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 05:22:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Kingdon 2005-02-03 16:25:54 UTC
Description of problem:

When I plug in my handy-dandy USB to serial/parallel box (Keyspan
UPR-112 if it matters, but this seems to apply to all such devices),
the parallel device /dev/usb/lp0 is automatically created just fine. 
The same is not true of /dev/usb/ttyUSB0, but it should be.

Version-Release number of selected component (if applicable):

udev-039-10.FC3.6 (installed Fedora Core 3 from CD, then applied all
updates to 3 Feb via yum.  So I have hal, etc, in case that matters).

Additional info:

The problem was fixed by adding the following to 
/etc/udev/rules.d/60-local.rules .  This bug is a request to have such
a line added to the default configuration.

BUS="usb", KERNEL="ttyUSB[0-9]*", NAME="usb/%k"

(assuming, of course, that my understanding is right about how all
this udev stuff is supposed to work).

Comment 1 Harald Hoyer 2005-02-03 18:28:11 UTC
what about the created /dev/ttyUSB* ?

Comment 2 Jim Kingdon 2005-02-04 05:22:16 UTC
Ah, OK.

The default created /dev/ttyUSB* has different permissions/owner/group
than the ones which I get with the rule I posted, but adding myself to
group uucp took care of it.

Not that I'm going to claim that I tried to put it in /dev/usb for
reasons of permissions.  I just didn't know to look in /dev/ttyUSB0.

So this bug should be closed (unless of course there is some
documentation which could have pointed me in the right direction, but
I'm not sure there's any place I looked which could have done so).



Note You need to log in before you can comment on or make changes to this bug.