Bug 1470057 - Review Request: perl-Locale-Utils-PlaceholderNamed - Utils to expand named placeholders
Review Request: perl-Locale-Utils-PlaceholderNamed - Utils to expand named pl...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 07:00 EDT by Jitka Plesnikova
Modified: 2017-07-18 07:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 07:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ppisar: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Comment 1 Petr Pisar 2017-07-17 07:01:40 EDT
URL and Source0 addresses are Ok.
Source0 archive (SHA-256: 173bfe9f83935ed89a3b636c87f74b222489d88ab022a64d3b6485dd1987c2ec) is original. Ok.
Summary verified from lib/Locale/Utils/PlaceholderNamed.pm. Ok.
Description is Ok.
License verified from lib/Locale/Utils/PlaceholderNamed.pm and README. Ok.
No XS code, noarch BuilArch is Ok.
Test::Exception and Test::Prereq::Build are not used. Ok.
Test::Perl::Critic not helpful. Ok.
All tests pass. Ok.

$ rpmlint perl-Locale-Utils-PlaceholderNamed.spec ../SRPMS/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.src.rpm ../RPMS/noarch/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.noarch.rpm 
2 packages and 1 specfiles checked; 0 errors, 0 warnings.
rpmlint is Ok.

$ rpm -q -lv -p ../RPMS/noarch/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.noarch.rpm
drwxr-xr-x    2 root    root                        0 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed
-rw-r--r--    1 root    root                      744 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/Changes
-rw-r--r--    1 root    root                      646 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/README
drwxr-xr-x    2 root    root                        0 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/example
-rw-r--r--    1 root    root                     1174 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/example/01_expand_named.pl
-rw-r--r--    1 root    root                     1050 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/example/02_modifier_code.pl
drwxr-xr-x    2 root    root                        0 Feb 24 14:40 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/javascript
drwxr-xr-x    2 root    root                        0 Feb 24 14:40 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/javascript/Locale
drwxr-xr-x    2 root    root                        0 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/javascript/Locale/Utils
-rw-r--r--    1 root    root                     1625 Jul 17 11:56 /usr/share/doc/perl-Locale-Utils-PlaceholderNamed/javascript/Locale/Utils/PlaceholderNamed.js
-rw-r--r--    1 root    root                     2420 Jul 17 11:56 /usr/share/man/man3/Locale::Utils::PlaceholderNamed.3pm.gz
drwxr-xr-x    2 root    root                        0 Jul 17 11:56 /usr/share/perl5/vendor_perl/Locale
drwxr-xr-x    2 root    root                        0 Jul 17 11:56 /usr/share/perl5/vendor_perl/Locale/Utils
-rw-r--r--    1 root    root                     4926 Feb 24 14:26 /usr/share/perl5/vendor_perl/Locale/Utils/PlaceholderNamed.pm
File layout and permissions are Ok.

$ rpm -q --requires -p ../RPMS/noarch/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.noarch.rpm | sort -f | uniq -c
      1 perl(:MODULE_COMPAT_5.26.0)
      1 perl(Carp)
      1 perl(Moo) >= 1.003001
      1 perl(MooX::StrictConstructor)
      1 perl(MooX::Types::MooseLike::Base)
      1 perl(namespace::autoclean)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -q --provides -p ../RPMS/noarch/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.noarch.rpm | sort -f | uniq -c
      1 perl(Locale::Utils::PlaceholderNamed) = 1.002
      1 perl-Locale-Utils-PlaceholderNamed = 1.002-1.fc27
Binary provides are Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-Locale-Utils-PlaceholderNamed-1.002-1.fc27.noarch.rpm 
Binary dependencies resolvable. Ok.

The package builds in F27 (https://koji.fedoraproject.org/koji/taskinfo?taskID=20573610). Ok.

The package is in line with Fedora and Perl packaging guidelines.
Resolution: Package APPROVED.
Comment 2 Gwyn Ciesla 2017-07-17 19:47:02 EDT
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/perl-Locale-Utils-PlaceholderNamed

Note You need to log in before you can comment on or make changes to this bug.