Bug 1470064 - ldbsearch and ldbedit segmentation fault in F26
ldbsearch and ldbedit segmentation fault in F26
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libldb (Show other bugs)
26
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 07:19 EDT by Petr Čech
Modified: 2017-07-14 05:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 05:04:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Čech 2017-07-12 07:19:48 EDT
Description of problem:
It is not possible to use ldbsearch and ldbedit after upgrade to F26.
(And for example use SSSD to login as user with kerberos password)

Version-Release number of selected component (if applicable):
libldb-1.2.0-2.fc26.x86_64 

How reproducible:
I hit it once.

Steps to Reproduce:
  Update Fedora from F25 to F26 by
    https://fedoramagazine.org/upgrading-fedora-25-fedora-26/
  Try to use ldbsearch or ldbedit on .ldb file

Actual results:
Segmentation fault

Expected results:
No Segmentation fault

Additional info:
Those versions are OK:
  libldb-1.1.29-1.fc25.x86_64
  libldb-1.1.29-5.fc26
Comment 1 Jakub Hrozek 2017-07-12 10:42:55 EDT
Are you sure you have also the same versions of ldb-tools?
Comment 2 Petr Čech 2017-07-14 02:54:37 EDT
Versions of libldb and ldb-tools are:
$ rpm -qa | grep libldb
libldb-1.2.0-2.fc26.x86_64
$ rpm -qa | grep ldb-tools
ldb-tools-1.2.0-2.fc26.x86_64

If you would like reproduce it, just enable Copr repo for freeipa-master owned by @freeipa:

$ cat /etc/yum.repos.d/_copr_@freeipa-freeipa-master.repo 
[group_freeipa-freeipa-master]
name=Copr repo for freeipa-master owned by @freeipa
baseurl=https://copr-be.cloud.fedoraproject.org/results/@freeipa/freeipa-master/fedora-$releasever-$basearch/
type=rpm-md
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/@freeipa/freeipa-master/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1
Comment 3 Lukas Slebodnik 2017-07-14 05:04:57 EDT
libldb-1.2.0-2.fc26.x86_64 and libldb-1.1.30 broke ABI. Therefore upgrade of libldb requires rebuilding of samba and sssd with new version of libldb.

Samba in f26 is not compatible with libldb-1.2.0 and libldb-1.2.0 is not and will not be in standard f26 repositories. Therefore closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.