Bug 1470148 - "katello-backup --online-backup" is not working properly
"katello-backup --online-backup" is not working properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Backup & Restore (Show other bugs)
6.2.9
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Christine Fouant
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 08:58 EDT by Rajan Gupta
Modified: 2018-03-21 14:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-21 14:22:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajan Gupta 2017-07-12 08:58:56 EDT
Description of problem:"katello-backup --online-backup" is not working properly
- Size of /var/lib/pulp is 300GBs where as backup created was of size approx 1GB.
- Same result on nfs directory as well on local backup directory.

Version-Release number of selected component (if applicable):
Satellite 6.2.9
Comment 10 Christine Fouant 2018-03-21 14:22:29 EDT
Hi team - my apologies that this has not been on my radar. I have been unable to reproduce this issue either on 6.2.14 or 6.3.


6.2.14
# du -sh /var/lib/pulp/
159M	/var/lib/pulp/

# ls -alsh /tmp/backup/katello-backup-20180321121156/
total 6.9G
   0 drwxrwx---. 3 root     postgres  195 Mar 21 12:36 .
   0 drwxr-xr-x. 3 root     root       43 Mar 21 12:11 ..
953M -rw-r--r--. 1 postgres postgres 953M Mar 21 12:36 candlepin.dump
3.9G -rw-r--r--. 1 root     root     3.9G Mar 21 12:18 config_files.tar.gz
9.4M -rw-r--r--. 1 root     root     9.4M Mar 21 12:18 .config.snar
1.9G -rw-r--r--. 1 postgres postgres 1.9G Mar 21 12:34 foreman.dump
 40K -rw-r--r--. 1 root     root      37K Mar 21 12:12 metadata.yml
   0 drwxr-xr-x. 5 root     root       52 Mar 21 13:42 mongo_dump
4.0K -rw-r--r--. 1 postgres postgres  650 Mar 21 12:29 pg_globals.dump
220M -rw-r--r--. 1 root     root     220M Mar 21 12:29 pulp_data.tar
1.6M -rw-r--r--. 1 root     root     1.6M Mar 21 12:29 .pulp.snar

6.3.0
# du -sh /var/lib/pulp/
27G	/var/lib/pulp/

# ls -ashl /tmp/backup/satellite-backup-20180321123129/
total 30G
   0 drwxrwx---. 3 root     postgres  195 Mar 21 13:16 .
   0 drwxr-xr-x. 4 root     root       84 Mar 21 12:31 ..
8.6M -rw-r--r--. 1 postgres postgres 8.6M Mar 21 13:16 candlepin.dump
5.9M -rw-r--r--. 1 root     root     5.8M Mar 21 12:31 config_files.tar.gz
 52K -rw-r--r--. 1 root     root      49K Mar 21 12:31 .config.snar
 35M -rw-r--r--. 1 postgres postgres  35M Mar 21 13:16 foreman.dump
 52K -rw-r--r--. 1 root     root      49K Mar 21 12:31 metadata.yml
   0 drwxr-xr-x. 5 root     root       52 Mar 21 13:19 mongo_dump
4.0K -rw-r--r--. 1 postgres postgres  650 Mar 21 13:16 pg_globals.dump
 30G -rw-r--r--. 1 root     root      30G Mar 21 13:15 pulp_data.tar
 90M -rw-r--r--. 1 root     root      90M Mar 21 13:15 .pulp.snar


Responding to comment 3, it is the case if pulp data is updating, that the online backup cannot be performed (unless --skip-pulp-content is selected). It states pretty explicitly in the docs that online backup should only be performed when Pulp is not running any tasks or updating the database. The pulp.snar issue is a bug and has been fixed.

Please let me know if you have any other questions. Thanks!

Note You need to log in before you can comment on or make changes to this bug.