Bug 1470305 - RFE: drop hgdistver dependency
RFE: drop hgdistver dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-execnet (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 13:17 EDT by Ken Dreyer
Modified: 2017-07-15 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-15 07:12:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drop hgdistver in rawhide (1.94 KB, patch)
2017-07-12 13:30 EDT, Ken Dreyer
no flags Details | Diff

  None (edit)
Description Ken Dreyer 2017-07-12 13:17:45 EDT
Description of problem:
We can slim down the build dependencies of python-execnet by dropping BuildRequires: python-hgdistver and python3-hgdistver and using the SETUPTOOLS_SCM_PRETEND_VERSION environment variable instead during the %build and %install steps.

Version-Release number of selected component (if applicable):
python-execnet-1.4.1-5.fc26
Comment 1 Ken Dreyer 2017-07-12 13:30 EDT
Created attachment 1297138 [details]
drop hgdistver in rawhide

I've verified that this satisfies the test case from the earlier BZ 1208984:

  $ cat etest.py 
  #!/usr/bin/python
  from pkg_resources import require
  require('execnet>=1.1dev1')

This require statement does not raise, and hgdistver is not installed in my environment.

You can pull the changes from my Git fork here or apply the patch I'm attaching to this BZ.

The following changes since commit 78984c1be4dba71dc61444f7860c1457d5635b23:

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild (2017-02-11 08:57:50 +0000)

are available in the git repository at:

  git://fedorapeople.org/home/fedora/ktdreyer/public_git/python-execnet.git 

for you to fetch changes up to b38896acf0a4e4674dc4af64df0f0a0033c5f592:

  drop hgdistver dependency by overriding setuptools-scm version (2017-07-12 11:21:57 -0600)

----------------------------------------------------------------
Ken Dreyer (1):
      drop hgdistver dependency by overriding setuptools-scm version

 python-execnet.spec | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)
Comment 2 Thomas Moschny 2017-07-15 07:12:25 EDT
Thanks for the patch! Applied and built for rawhide:
https://koji.fedoraproject.org/koji/buildinfo?buildID=918965
Comment 3 Ken Dreyer 2017-07-15 22:20:09 EDT
Awesome, thanks Thomas!

Note You need to log in before you can comment on or make changes to this bug.