Bug 1470346 - Upgrade 25 to 26 with DNF system upgrade results in 25 on machine with dnf broken
Upgrade 25 to 26 with DNF system upgrade results in 25 on machine with dnf br...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
:
: 1472536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 15:10 EDT by Sam
Modified: 2017-10-25 12:32 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1472536 (view as bug list)
Environment:
Last Closed: 2017-07-25 10:57:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped journalctl -t dnf lines from July 11 when the 25->26 upgrade was attempted (22.60 KB, application/x-gzip)
2017-07-20 09:07 EDT, Sam
no flags Details
Output from rpm -qa --qf "%{NAME} " (29.55 KB, text/plain)
2017-07-21 13:31 EDT, Sam
no flags Details

  None (edit)
Description Sam 2017-07-12 15:10:52 EDT
Description of problem:

I used DNF System Upgrade as per https://fedoraproject.org/wiki/DNF_system_upgrade to upgrade a VM from Fedora 25 to 26. When it was done upgrading packages, it booted into 25 and now dnf throws the following error:

[root@sirius sam]# dnf
Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    from dnf.cli import main
ModuleNotFoundError: No module named 'dnf'
[root@sirius sam]# 

I cannot therefore move forward with DNF to try to get the upgrade to 26 to work. The machine does run 25 fine.

Version-Release number of selected component (if applicable):

25

How reproducible:

Not sure

Steps to Reproduce:
1. sudo dnf upgrade --refresh
2. sudo dnf system-upgrade download --refresh --releasever=26
3. sudo dnf system-upgrade reboot

Actual results:
Machine boots into Fedora 25 and that's it. dnf is broken.

Expected results:
Machine boots into Fedora 25, updates grub, and then reboots into Fedora 26.

Additional info:
This also happened to me once going from Fedora 24 to 25 on another VM. I ended up giving up and doing a fresh install of Fedora 25.
Comment 1 Sam 2017-07-12 15:17:46 EDT
Just thought I'd add this:

[root@sirius sam]# cat /etc/redhat-release 
Fedora release 25 (Twenty Five)
Comment 2 Vinícius Henrique Ponciano Ribeiro 2017-07-18 21:54:36 EDT
I had the same problem, but in my case my notebook battery died when the restart process was in course, triggered by command sudo dnf system-upgrade reboot.
Comment 3 Daniel Mach 2017-07-19 07:24:00 EDT
*** Bug 1472536 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Mracek 2017-07-20 06:54:34 EDT
I think that we need to know what happened during reboot. The information could be found by systemd journalctl or by dnf log /var/log/dnf.log

Please can you try to gather the information from the logs?

Then please can you try some dnf commands like:

'dnf-2 repolist'
'dnf-3 repolist'


Thanks a lot for any additional information
Comment 5 Sam 2017-07-20 09:05:12 EDT
As reported, dnf is broken. dnf-2 works, dnf-3 fails with the missing dnf module error.

[sam@sirius ~]$ dnf-2 repolist
Fedora 25 - x86_64                                                                                                                                                                  9.3 MB/s |  50 MB     00:05    
RPM Fusion for Fedora 25 - Free - Updates                                                                                                                                           1.3 MB/s | 290 kB     00:00    
RPM Fusion for Fedora 25 - Nonfree - Updates                                                                                                                                        345 kB/s |  40 kB     00:00    
Fedora 25 - x86_64 - Updates                                                                                                                                                        9.2 MB/s |  24 MB     00:02    
Last metadata expiration check: 0:00:10 ago on Thu Jul 20 07:57:54 2017.
repo id                                                                                       repo name                                                                                                       status
*fedora                                                                                       Fedora 25 - x86_64                                                                                              51,669
*rpmfusion-free-updates                                                                       RPM Fusion for Fedora 25 - Free - Updates                                                                          224
*rpmfusion-nonfree-updates                                                                    RPM Fusion for Fedora 25 - Nonfree - Updates                                                                        55
*updates                                                                                      Fedora 25 - x86_64 - Updates                                                                                    20,724

[sam@sirius ~]$ dnf-3 repolist
Traceback (most recent call last):
  File "/usr/bin/dnf-3", line 57, in <module>
    from dnf.cli import main
ModuleNotFoundError: No module named 'dnf'

And I've added as an attachment (it's long) all the journalctl -t dnf lines from the fateful day, July 11: journalctl.dnf.Jul11.txt
Comment 6 Sam 2017-07-20 09:07 EDT
Created attachment 1301698 [details]
gzipped journalctl -t dnf lines from July 11 when the 25->26 upgrade was attempted
Comment 7 Jaroslav Mracek 2017-07-21 02:41:10 EDT
I guess that at the present time you have about 388 duplicates on your system including python, system-python (used by dnf-3) and so on.

First of all you have to remove duplicates.  

Probably this article could help: http://dnf.baseurl.org/2016/12/15/repair-of-broken-system-with-dnf-2-0/

But keep in mind, that some of the new installed packages can have insufficient dependencies, therefore be careful. Also handle it from console would be a better option. Or repair from outside using installroot like it is described in article would be the best way. After than you will get all duplicates out of your system, try to use distrosync (or upgrade) for "--releasever 26" (also from outside using installroot would be the best). 

Additionally please can you provide an output from "dnf-2 repoquery *dnf* --installed"?

So far I am unable to find out the primary cause of your problem, therefore what I can do is to help you to get your system into right shape.
Comment 8 Sam 2017-07-21 10:22:48 EDT
Thanks for all the help, Jaroslav, looks like that gives me a path forward towards 26. As for your request:

[sam@sirius ~]$ sudo dnf-2 repoquery *dnf* --installed
[sudo] password for sam: 
No such command: repoquery. Please use /bin/dnf-2 --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(repoquery)'"

Looks like that command is broken as well, given the dnf plugin brokenness. I'm happy to try any other options.

The package duplicates are, of course, due to the F26+F25 botch. If I had dnf I could fix all this, I think. ;)
Comment 9 Jaroslav Mracek 2017-07-21 10:44:42 EDT
No command 'repoquery' is not broken, only python2-dnf-plugins-core (plugins for python2 version) is not installed.

Same information can be retrieve by "rpm -qa | grep dnf" or "dnf list installed '*dnf*'"

Please if you will find any additional problem with restoring your system, don't hesitate to ask.
Comment 10 Jaroslav Mracek 2017-07-21 10:47:02 EDT
I meant "dnf-2 list installed '*dnf*'" for your case.
Comment 11 Sam 2017-07-21 10:49:11 EDT
Yeah, since I don't have dnf, I can't install plugins - or anything else. I've tried to download RPMs and go from there, but no luck. Here's the rpm results:

[sam@sirius ~]$ sudo rpm -qa | grep dnf
python2-dnf-1.1.10-6.fc25.noarch
dnf-conf-2.5.1-1.fc26.noarch
python3-dnf-plugins-core-0.1.21-5.fc25.noarch
python3-dnf-1.1.10-6.fc25.noarch
dnf-1.1.10-6.fc25.noarch
dnf-plugins-core-0.1.21-5.fc25.noarch
libdnf-0.7.3-1.fc25.x86_64
dnf-conf-1.1.10-6.fc25.noarch

If you can think of a path forward just using rpm (since DNF is broken, but I can download RPMs), I'd be much appreciative!
Comment 12 Jaroslav Mracek 2017-07-21 11:14:04 EDT
Why you don't want to use Fedora live medium to restore your system like it is described in article in Comment 7 . I strongly recommend this approach because the changes will not interfere with your running environment.

Other option would by to remove duplicates on your computer:
Do it in console (ctr+alt+F3)
1. sudo dnf-2 install python2-dnf-plugins-core (may be --alloweranig will be required)

2. sudo dnf-2 repoquery --duplicates --installed
# it should provide list of all duplicates

3. Remove duplicates and after that reinstall remaining packages (this is more risky)
Comment 13 Sam 2017-07-21 12:24:44 EDT
Thanks, I'm fine with the Fedora live medium solution, albeit this is on a VM across the country, so I have to deal with virtual disk mounts and stuff. I was just hoping that a couple quick rpm commands might get me back to where I can install dnf and be on my way. :) I may try your dnf-2 suggestion for a short time before I dive into the live medium update.

In any case, we've veered into solving MY problem. But the bug report is about the dnf-system-upgrade failure on a pretty normal F25 machine. I think it's a bug, I've hit it on two machines so far, both VMs. Certainly, if one follows the simple instructions to the letter and finds oneself with a F25 machine in which dnf is broken, it's a "bug."
Comment 14 Jaroslav Mracek 2017-07-21 12:37:54 EDT
Ok, please can you provide an output of rpm -qa --qf "%{NAME} " plus description what kind of VM you have (including resources that can be used by VM) to have something like a good possibility of reproduction.
You can be sure that I would like to find out the primary cause but so fire I am unable to reproduce your problem.
Comment 15 Jaroslav Mracek 2017-07-21 12:41:42 EDT
You can also access vm disk from the host when vm is off. Then you can use --installroot to fix it but I strongly recommend to use dnf-2.5+ from our test repository (dnf copr enable rpmsoftwaremanagement/dnf-nightly).
Comment 16 Sam 2017-07-21 13:31 EDT
Created attachment 1302499 [details]
Output from rpm -qa --qf "%{NAME} "

Here's the output from rpm -qa --qf "%{NAME} "
Comment 17 Sam 2017-07-21 13:37:49 EDT
The VM is KVM running on Fedora release 25. Here's a virsh dump:

virsh # dominfo sirius
Id:             1105
Name:           sirius
UUID:           7b1321d1-09e6-47d8-9f3c-4886c519ec82
OS Type:        hvm
State:          running
CPU(s):         2
CPU time:       522.4s
Max memory:     4194304 KiB
Used memory:    4194304 KiB
Persistent:     yes
Autostart:      enable
Managed save:   no
Security model: none
Security DOI:   0

virsh # domstats sirius
Domain: 'sirius'
  state.state=1
  state.reason=1
  cpu.time=525399388890
  cpu.user=8640000000
  cpu.system=104140000000
  balloon.current=4194304
  balloon.maximum=4194304
  balloon.swap_in=0
  balloon.swap_out=0
  balloon.major_fault=293
  balloon.minor_fault=90838
  balloon.unused=3932672
  balloon.available=4045412
  balloon.usable=3846572
  balloon.last-update=1500618887
  balloon.rss=2146788
  vcpu.current=2
  vcpu.maximum=2
  vcpu.0.state=1
  vcpu.0.time=246910000000
  vcpu.0.wait=0
  vcpu.1.state=1
  vcpu.1.time=251750000000
  vcpu.1.wait=0
  net.count=1
  net.0.name=vnet3
  net.0.rx.bytes=4779704
  net.0.rx.pkts=62788
  net.0.rx.errs=0
  net.0.rx.drop=0
  net.0.tx.bytes=2030097
  net.0.tx.pkts=12095
  net.0.tx.errs=0
  net.0.tx.drop=0
  block.count=2
  block.0.name=vda
  block.0.path=/var/lib/libvirt/images/sirius.qcow2
  block.0.rd.reqs=36311
  block.0.rd.bytes=901136384
  block.0.rd.times=836150097512
  block.0.wr.reqs=34092
  block.0.wr.bytes=215856128
  block.0.wr.times=30846016703
  block.0.fl.reqs=9609
  block.0.fl.times=181082913021
  block.0.allocation=159660441600
  block.0.capacity=107374182400
  block.0.physical=105263915008
  block.1.name=hda
  block.1.rd.reqs=4
  block.1.rd.bytes=152
  block.1.rd.times=130566
  block.1.wr.reqs=0
  block.1.wr.bytes=0
  block.1.wr.times=0
  block.1.fl.reqs=0
  block.1.fl.times=0
  block.1.allocation=0

<sysinfo type='smbios'>
  <bios>
    <entry name='vendor'>American Megatrends Inc.</entry>
    <entry name='version'>3.0a</entry>
    <entry name='date'>12/04/2013</entry>
    <entry name='release'>3.10</entry>
  </bios>
  <system>
    <entry name='manufacturer'>Supermicro</entry>
    <entry name='product'>X9DRE-TF+/X9DR7-TF+</entry>
    <entry name='version'>0123456789</entry>
    <entry name='serial'>0123456789</entry>
    <entry name='uuid'>00000000-0000-0000-0000-002590898D8A</entry>
    <entry name='sku'>To be filled by O.E.M.</entry>
    <entry name='family'>To be filled by O.E.M.</entry>
  </system>
  <baseBoard>
    <entry name='manufacturer'>Supermicro</entry>
    <entry name='product'>X9DRE-TF+/X9DR7-TF+</entry>
    <entry name='version'>0123456789</entry>
    <entry name='serial'>OM132S015312</entry>
    <entry name='asset'>To be filled by O.E.M.</entry>
    <entry name='location'>To be filled by O.E.M.</entry>
  </baseBoard>
  <processor>
    <entry name='socket_destination'>CPU 1</entry>
    <entry name='type'>Central Processor</entry>
    <entry name='family'>Xeon</entry>
    <entry name='manufacturer'>Intel</entry>
    <entry name='signature'>Type 0, Family 6, Model 62, Stepping 4</entry>
    <entry name='version'>Intel(R) Xeon(R) CPU E5-2609 v2 @ 2.50GHz</entry>
    <entry name='external_clock'>100 MHz</entry>
    <entry name='max_speed'>4000 MHz</entry>
    <entry name='status'>Populated, Enabled</entry>
    <entry name='serial_number'>Not Specified</entry>
    <entry name='part_number'>Not Specified</entry>
  </processor>
  <processor>
    <entry name='socket_destination'>CPU 2</entry>
    <entry name='type'>Central Processor</entry>
    <entry name='family'>Xeon</entry>
    <entry name='manufacturer'>Intel</entry>
    <entry name='signature'>Type 0, Family 6, Model 62, Stepping 4</entry>
    <entry name='version'>Intel(R) Xeon(R) CPU E5-2609 v2 @ 2.50GHz</entry>
    <entry name='external_clock'>100 MHz</entry>
    <entry name='max_speed'>4000 MHz</entry>
    <entry name='status'>Populated, Enabled</entry>
    <entry name='serial_number'>Not Specified</entry>
    <entry name='part_number'>Not Specified</entry>
  </processor>
  <memory_device>
    <entry name='size'>16384 MB</entry>
    <entry name='form_factor'>DIMM</entry>
    <entry name='locator'>P1-DIMMA1</entry>
    <entry name='bank_locator'>P0_Node0_Channel0_Dimm0</entry>
    <entry name='type'>DDR3</entry>
    <entry name='type_detail'>Registered (Buffered)</entry>
    <entry name='speed'>1333 MHz</entry>
    <entry name='manufacturer'>Samsung</entry>
    <entry name='serial_number'>141A30A7</entry>
    <entry name='part_number'>M393B2G70QH0-YK0</entry>
  </memory_device>
  <memory_device>
    <entry name='size'>16384 MB</entry>
    <entry name='form_factor'>DIMM</entry>
    <entry name='locator'>P1-DIMMB1</entry>
    <entry name='bank_locator'>P0_Node0_Channel1_Dimm0</entry>
    <entry name='type'>DDR3</entry>
    <entry name='type_detail'>Registered (Buffered)</entry>
    <entry name='speed'>1333 MHz</entry>
    <entry name='manufacturer'>Samsung</entry>
    <entry name='serial_number'>141C5789</entry>
    <entry name='part_number'>M393B2G70QH0-YK0</entry>
  </memory_device>
  <memory_device>
    <entry name='size'>16384 MB</entry>
    <entry name='form_factor'>DIMM</entry>
    <entry name='locator'>P2-DIMME1</entry>
    <entry name='bank_locator'>P1_Node1_Channel0_Dimm0</entry>
    <entry name='type'>DDR3</entry>
    <entry name='type_detail'>Registered (Buffered)</entry>
    <entry name='speed'>1333 MHz</entry>
    <entry name='manufacturer'>Samsung</entry>
    <entry name='serial_number'>141A30A0</entry>
    <entry name='part_number'>M393B2G70QH0-YK0</entry>
  </memory_device>
  <memory_device>
    <entry name='size'>16384 MB</entry>
    <entry name='form_factor'>DIMM</entry>
    <entry name='locator'>P2-DIMMF1</entry>
    <entry name='bank_locator'>P1_Node1_Channel1_Dimm0</entry>
    <entry name='type'>DDR3</entry>
    <entry name='type_detail'>Registered (Buffered)</entry>
    <entry name='speed'>1333 MHz</entry>
    <entry name='manufacturer'>Samsung</entry>
    <entry name='serial_number'>141A31CE</entry>
    <entry name='part_number'>M393B2G70QH0-YK0</entry>
  </memory_device>
</sysinfo>

virsh # capabilities
<capabilities>

  <host>
    <uuid>00000000-0000-0000-0000-002590898d8a</uuid>
    <cpu>
      <arch>x86_64</arch>
      <model>IvyBridge</model>
      <vendor>Intel</vendor>
      <topology sockets='1' cores='4' threads='1'/>
      <feature name='ds'/>
      <feature name='acpi'/>
      <feature name='ss'/>
      <feature name='ht'/>
      <feature name='tm'/>
      <feature name='pbe'/>
      <feature name='dtes64'/>
      <feature name='monitor'/>
      <feature name='ds_cpl'/>
      <feature name='vmx'/>
      <feature name='smx'/>
      <feature name='est'/>
      <feature name='tm2'/>
      <feature name='xtpr'/>
      <feature name='pdcm'/>
      <feature name='pcid'/>
      <feature name='dca'/>
      <feature name='osxsave'/>
      <feature name='arat'/>
      <feature name='xsaveopt'/>
      <feature name='pdpe1gb'/>
      <feature name='invtsc'/>
      <pages unit='KiB' size='4'/>
      <pages unit='KiB' size='2048'/>
      <pages unit='KiB' size='1048576'/>
    </cpu>
    <power_management>
      <suspend_mem/>
      <suspend_disk/>
      <suspend_hybrid/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
        <uri_transport>rdma</uri_transport>
      </uri_transports>
    </migration_features>
    <topology>
      <cells num='2'>
        <cell id='0'>
          <memory unit='KiB'>32927432</memory>
          <pages unit='KiB' size='4'>8231858</pages>
          <pages unit='KiB' size='2048'>0</pages>
          <pages unit='KiB' size='1048576'>0</pages>
          <distances>
            <sibling id='0' value='10'/>
            <sibling id='1' value='21'/>
          </distances>
          <cpus num='4'>
            <cpu id='0' socket_id='0' core_id='0' siblings='0'/>
            <cpu id='1' socket_id='0' core_id='1' siblings='1'/>
            <cpu id='2' socket_id='0' core_id='2' siblings='2'/>
            <cpu id='3' socket_id='0' core_id='3' siblings='3'/>
          </cpus>
        </cell>
        <cell id='1'>
          <memory unit='KiB'>33014348</memory>
          <pages unit='KiB' size='4'>8253587</pages>
          <pages unit='KiB' size='2048'>0</pages>
          <pages unit='KiB' size='1048576'>0</pages>
          <distances>
            <sibling id='0' value='21'/>
            <sibling id='1' value='10'/>
          </distances>
          <cpus num='4'>
            <cpu id='4' socket_id='1' core_id='0' siblings='4'/>
            <cpu id='5' socket_id='1' core_id='1' siblings='5'/>
            <cpu id='6' socket_id='1' core_id='2' siblings='6'/>
            <cpu id='7' socket_id='1' core_id='3' siblings='7'/>
          </cpus>
        </cell>
      </cells>
    </topology>
    <secmodel>
      <model>none</model>
      <doi>0</doi>
    </secmodel>
    <secmodel>
      <model>dac</model>
      <doi>0</doi>
      <baselabel type='kvm'>+107:+107</baselabel>
      <baselabel type='qemu'>+107:+107</baselabel>
    </secmodel>
  </host>

  <guest>
    <os_type>hvm</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-i386</emulator>
      <machine maxCpus='255'>pc-i440fx-2.7</machine>
      <machine canonical='pc-i440fx-2.7' maxCpus='255'>pc</machine>
      <machine maxCpus='255'>pc-0.12</machine>
      <machine maxCpus='255'>pc-i440fx-2.4</machine>
      <machine maxCpus='255'>pc-1.3</machine>
      <machine maxCpus='255'>pc-q35-2.7</machine>
      <machine canonical='pc-q35-2.7' maxCpus='255'>q35</machine>
      <machine maxCpus='255'>pc-q35-2.6</machine>
      <machine maxCpus='1'>xenpv</machine>
      <machine maxCpus='255'>pc-i440fx-1.7</machine>
      <machine maxCpus='255'>pc-i440fx-1.6</machine>
      <machine maxCpus='255'>pc-0.11</machine>
      <machine maxCpus='255'>pc-i440fx-2.3</machine>
      <machine maxCpus='255'>pc-0.10</machine>
      <machine maxCpus='255'>pc-1.2</machine>
      <machine maxCpus='255'>pc-i440fx-2.2</machine>
      <machine maxCpus='1'>isapc</machine>
      <machine maxCpus='255'>pc-q35-2.5</machine>
      <machine maxCpus='128'>xenfv</machine>
      <machine maxCpus='255'>pc-0.15</machine>
      <machine maxCpus='255'>pc-0.14</machine>
      <machine maxCpus='255'>pc-i440fx-1.5</machine>
      <machine maxCpus='255'>pc-i440fx-2.6</machine>
      <machine maxCpus='255'>pc-i440fx-1.4</machine>
      <machine maxCpus='255'>pc-i440fx-2.5</machine>
      <machine maxCpus='255'>pc-1.1</machine>
      <machine maxCpus='255'>pc-i440fx-2.1</machine>
      <machine maxCpus='255'>pc-1.0</machine>
      <machine maxCpus='255'>pc-i440fx-2.0</machine>
      <machine maxCpus='255'>pc-q35-2.4</machine>
      <machine maxCpus='255'>pc-0.13</machine>
      <domain type='qemu'/>
      <domain type='kvm'>
        <emulator>/usr/bin/qemu-kvm</emulator>
        <machine maxCpus='255'>pc-i440fx-2.7</machine>
        <machine canonical='pc-i440fx-2.7' maxCpus='255'>pc</machine>
        <machine maxCpus='255'>pc-0.12</machine>
        <machine maxCpus='255'>pc-i440fx-2.4</machine>
        <machine maxCpus='255'>pc-1.3</machine>
        <machine maxCpus='255'>pc-q35-2.7</machine>
        <machine canonical='pc-q35-2.7' maxCpus='255'>q35</machine>
        <machine maxCpus='255'>pc-q35-2.6</machine>
        <machine maxCpus='1'>xenpv</machine>
        <machine maxCpus='255'>pc-i440fx-1.7</machine>
        <machine maxCpus='255'>pc-i440fx-1.6</machine>
        <machine maxCpus='255'>pc-0.11</machine>
        <machine maxCpus='255'>pc-i440fx-2.3</machine>
        <machine maxCpus='255'>pc-0.10</machine>
        <machine maxCpus='255'>pc-1.2</machine>
        <machine maxCpus='255'>pc-i440fx-2.2</machine>
        <machine maxCpus='1'>isapc</machine>
        <machine maxCpus='255'>pc-q35-2.5</machine>
        <machine maxCpus='128'>xenfv</machine>
        <machine maxCpus='255'>pc-0.15</machine>
        <machine maxCpus='255'>pc-0.14</machine>
        <machine maxCpus='255'>pc-i440fx-1.5</machine>
        <machine maxCpus='255'>pc-i440fx-2.6</machine>
        <machine maxCpus='255'>pc-i440fx-1.4</machine>
        <machine maxCpus='255'>pc-i440fx-2.5</machine>
        <machine maxCpus='255'>pc-1.1</machine>
        <machine maxCpus='255'>pc-i440fx-2.1</machine>
        <machine maxCpus='255'>pc-1.0</machine>
        <machine maxCpus='255'>pc-i440fx-2.0</machine>
        <machine maxCpus='255'>pc-q35-2.4</machine>
        <machine maxCpus='255'>pc-0.13</machine>
      </domain>
    </arch>
    <features>
      <cpuselection/>
      <deviceboot/>
      <disksnapshot default='on' toggle='no'/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
      <pae/>
      <nonpae/>
    </features>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/bin/qemu-system-x86_64</emulator>
      <machine maxCpus='255'>pc-i440fx-2.7</machine>
      <machine canonical='pc-i440fx-2.7' maxCpus='255'>pc</machine>
      <machine maxCpus='255'>pc-0.12</machine>
      <machine maxCpus='255'>pc-i440fx-2.4</machine>
      <machine maxCpus='255'>pc-1.3</machine>
      <machine maxCpus='255'>pc-q35-2.7</machine>
      <machine canonical='pc-q35-2.7' maxCpus='255'>q35</machine>
      <machine maxCpus='255'>pc-q35-2.6</machine>
      <machine maxCpus='1'>xenpv</machine>
      <machine maxCpus='255'>pc-i440fx-1.7</machine>
      <machine maxCpus='255'>pc-i440fx-1.6</machine>
      <machine maxCpus='255'>pc-0.11</machine>
      <machine maxCpus='255'>pc-i440fx-2.3</machine>
      <machine maxCpus='255'>pc-0.10</machine>
      <machine maxCpus='255'>pc-1.2</machine>
      <machine maxCpus='255'>pc-i440fx-2.2</machine>
      <machine maxCpus='1'>isapc</machine>
      <machine maxCpus='255'>pc-q35-2.5</machine>
      <machine maxCpus='128'>xenfv</machine>
      <machine maxCpus='255'>pc-0.15</machine>
      <machine maxCpus='255'>pc-0.14</machine>
      <machine maxCpus='255'>pc-i440fx-1.5</machine>
      <machine maxCpus='255'>pc-i440fx-2.6</machine>
      <machine maxCpus='255'>pc-i440fx-1.4</machine>
      <machine maxCpus='255'>pc-i440fx-2.5</machine>
      <machine maxCpus='255'>pc-1.1</machine>
      <machine maxCpus='255'>pc-i440fx-2.1</machine>
      <machine maxCpus='255'>pc-1.0</machine>
      <machine maxCpus='255'>pc-i440fx-2.0</machine>
      <machine maxCpus='255'>pc-q35-2.4</machine>
      <machine maxCpus='255'>pc-0.13</machine>
      <domain type='qemu'/>
      <domain type='kvm'>
        <emulator>/usr/bin/qemu-kvm</emulator>
        <machine maxCpus='255'>pc-i440fx-2.7</machine>
        <machine canonical='pc-i440fx-2.7' maxCpus='255'>pc</machine>
        <machine maxCpus='255'>pc-0.12</machine>
        <machine maxCpus='255'>pc-i440fx-2.4</machine>
        <machine maxCpus='255'>pc-1.3</machine>
        <machine maxCpus='255'>pc-q35-2.7</machine>
        <machine canonical='pc-q35-2.7' maxCpus='255'>q35</machine>
        <machine maxCpus='255'>pc-q35-2.6</machine>
        <machine maxCpus='1'>xenpv</machine>
        <machine maxCpus='255'>pc-i440fx-1.7</machine>
        <machine maxCpus='255'>pc-i440fx-1.6</machine>
        <machine maxCpus='255'>pc-0.11</machine>
        <machine maxCpus='255'>pc-i440fx-2.3</machine>
        <machine maxCpus='255'>pc-0.10</machine>
        <machine maxCpus='255'>pc-1.2</machine>
        <machine maxCpus='255'>pc-i440fx-2.2</machine>
        <machine maxCpus='1'>isapc</machine>
        <machine maxCpus='255'>pc-q35-2.5</machine>
        <machine maxCpus='128'>xenfv</machine>
        <machine maxCpus='255'>pc-0.15</machine>
        <machine maxCpus='255'>pc-0.14</machine>
        <machine maxCpus='255'>pc-i440fx-1.5</machine>
        <machine maxCpus='255'>pc-i440fx-2.6</machine>
        <machine maxCpus='255'>pc-i440fx-1.4</machine>
        <machine maxCpus='255'>pc-i440fx-2.5</machine>
        <machine maxCpus='255'>pc-1.1</machine>
        <machine maxCpus='255'>pc-i440fx-2.1</machine>
        <machine maxCpus='255'>pc-1.0</machine>
        <machine maxCpus='255'>pc-i440fx-2.0</machine>
        <machine maxCpus='255'>pc-q35-2.4</machine>
        <machine maxCpus='255'>pc-0.13</machine>
      </domain>
    </arch>
    <features>
      <cpuselection/>
      <deviceboot/>
      <disksnapshot default='on' toggle='no'/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

</capabilities>
Comment 18 Sam 2017-07-25 00:30:03 EDT
I managed to get the machine up to normal in Fedora 26 using the Fedora 26 CD, and interestingly I couldn't do it with the Fedora 25 CD because the rpm database had somehow been converted to F26 and threw errors on any f25 dnf attempts. F26 was just the usual remove/upgrade/install on dupes, old versions, etc. and once I got dnf working on the machine I could boot up and do a massive dnf upgrade, having already upgraded to fedora-release-26-1 and fedora-repos-26-1.

Since I do think there's an upgrade bug, at least on KVM VMs, I'm wondering if you'd like me to build a plain Fedora 25 from CD, upgrade it, then do the dnf system-upgrade to Fedora 26 and document what happens. I think there's a good chance it'll wind up in this purgatory between 25 and 26. I could give you a login to poke at it if you want.

Thanks for the help, though!
Comment 19 Sam 2017-07-25 10:57:55 EDT
Well, I went through the process, firing up a VM with the same parameters, installing F25 from "DVD", updating, rebooting, running

dnf system-upgrade download --refresh --releasever=26
dnf system-upgrade reboot

and the machine upgraded fine. Afterward the only F25 packages were the old kernel.

So I conclude this is not reproducible in a clean test. My problems before seemed to arise from a garfed-up python package, but this didn't happen this time.

So thanks again, Jaroslav, for all the help and I'll close this one.
Comment 20 David 2017-10-25 01:43:40 EDT
(In reply to Sam from comment #18)
> I managed to get the machine up to normal in Fedora 26 using the Fedora 26
> CD, and interestingly I couldn't do it with the Fedora 25 CD because the rpm
> database had somehow been converted to F26 and threw errors on any f25 dnf
> attempts. F26 was just the usual remove/upgrade/install on dupes, old
> versions, etc. and once I got dnf working on the machine I could boot up and
> do a massive dnf upgrade, having already upgraded to fedora-release-26-1 and
> fedora-repos-26-1.
> 
> Since I do think there's an upgrade bug, at least on KVM VMs, I'm wondering
> if you'd like me to build a plain Fedora 25 from CD, upgrade it, then do the
> dnf system-upgrade to Fedora 26 and document what happens. I think there's a
> good chance it'll wind up in this purgatory between 25 and 26. I could give
> you a login to poke at it if you want.
> 
> Thanks for the help, though!

I've encountered exactly the same problem. DNF broken when upgrading for F25 to F26. Would you please tell me how do you get you machine up to normal using the F26 CD.

Thank you very much.
Comment 21 Sam 2017-10-25 12:32:47 EDT
I booted into F26 Rescue Mode with the CD, changed my root to /mnt/sysimage, but used the dnf on the F26 disk. That allowed me to manually remove all the duplicate packages and install a working dnf on the machine. That allowed me to boot up the machine and use dnf to clean things up further.

My main problem was that dnf was broken, so I was able to use the F26 disk to get at a working dnf and do some updates to the machine's configuration.

Note You need to log in before you can comment on or make changes to this bug.