Bug 1470508 - Kickstart fails for btrfs with subvolumes on lvm
Kickstart fails for btrfs with subvolumes on lvm
Status: CLOSED DUPLICATE of bug 1470524
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 01:18 EDT by Pascal Ernster (old account, do not use)
Modified: 2017-07-13 02:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1470524 (view as bug list)
Environment:
Last Closed: 2017-07-13 02:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg created by the "normal" installation as described in the bug report (1.63 KB, text/plain)
2017-07-13 01:18 EDT, Pascal Ernster (old account, do not use)
no flags Details

  None (edit)
Description Pascal Ernster (old account, do not use) 2017-07-13 01:18:50 EDT
Created attachment 1297389 [details]
anaconda-ks.cfg created by the "normal" installation as described in the bug report

Description of problem:
When using the normal GUI installer, it is possible to install Fedora >=26 with btrfs on an LVM LV as root filesystem. However, the anaconda-ks.cfg generated during that install doesn't work when trying to reproduce that install using Kickstart.

Version-Release number of selected component (if applicable):
 - Fedora 26
 - Rawhide (boot.iso date: 2017-07-11)

How reproducible: constant/deterministic.

Steps to Reproduce:

 1. Install Fedora using the GUI installer and the advanced blivet-gui partitioning mode so that you get the following layout:
    - /dev/vda1 = /boot/efi (efiboot)
    - /dev/vda3 = /boot (ext4)
    - /dev/vda2 = pv.1
    - LVM VG "vgsystem" on pv.1
    - LVM LV "lvsystem" on LVM VG "vgsystem"
    - btrfs (with or without dedicated mountpoint) on LVM VM "lvsystem"
    - btrfs subvol "home" with mountpoint "/home"
    - btrfs subvol "fedora26" with mountpoint "/"
This install will go through and yield a bootable system with the requested partition layout.
Note: vda2 and vda3 are just interchanged because I first tried creating only /boot on the efiboot partition and then had to delete that partition and create both an efiboot and an ext4 boot partition in the same space because the installer was complaining about a missing dedicated /boot partition.

2. Use the /root/anaconda-ks.cfg from this new installation to reproduce the installation with kickstart on another machine. Anaconda will complain that no parent was specified for the btrfs subvolumes. Sadly I have also been unable to find a way to manually change the kickstart file to make it work. Btrfs subvolumes seem to rely on partition labels which aren't available when using an LVM LV.
Note: I have made sure that the second machine I tested the kickstart file on way completely wiped to eliminate this as a potential source of errors (First "wipefs -a" on the LVM LV, then lvremove, vgremove, then "wipefs -a" on all partitions, and only then wipefs -a on the harddisk itself).


Actual results:
- The "normal" GUI installation works for installing the system but produces a non-working anaconda-ks.cfg file.
- Kickstart seemingly cannot create a btrfs volume with btrfs subvolumes on an LVM LV.


Expected results:
- The "normal" GUI installation yields a working anaconda-ks.cfg file using which the installation can be reproduced on another machine.
- Kickstart allows me to create a btrfs volume with btrfs subvolumes on an LVM LV.


Additional info:
I've tested this with both Fedora 26 and Rawhide (boot.iso date: 2017-07-11), both are affected.
Comment 1 Pascal Ernster (old account, do not use) 2017-07-13 02:09:25 EDT

*** This bug has been marked as a duplicate of bug 1470524 ***

Note You need to log in before you can comment on or make changes to this bug.