Bug 1470592 - Unable to edit reports from non-admin user
Unable to edit reports from non-admin user
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
All Linux
high Severity high
: GA
: 5.8.2
Assigned To: Hilda Stastna
Niyaz Akhtar Ansari
report:rbac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 05:25 EDT by Neha Chugh
Modified: 2017-08-21 06:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 01:28:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Neha Chugh 2017-07-13 05:25:07 EDT
Description of problem:
Unable to edit reports from non-admin user 
Version-Release number of selected component (if applicable):
5.8.0

How reproducible:
Always

Steps to Reproduce:
1. create a non-admin user with reporting access(view,create,modify).
2. create a report from non-admin user. It will create a report.
3. While clicking the custom report, the cursor keep on spinning due to which the newly created report are not able to edit.

Actual results:
Unable to edit the newly created reports.

Expected results:
It should edit the newly created reports


Additional info:
It has been verified in Cloudforms 4.2 and its working as expected but not in Cloudforms 4.5.
Comment 8 Neha Chugh 2017-08-15 01:27:25 EDT
Hello Hilda,

I have tested in cfme -5.8.1 and its working as expected. We can close this bug as it is working find in latest version.

Thanks for all help.

Regards,
Neha Chugh

Note You need to log in before you can comment on or make changes to this bug.