Bug 1470594 - cannot install specific version - dnf? or kernel rpm problem?
cannot install specific version - dnf? or kernel rpm problem?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 05:29 EDT by lejeczek
Modified: 2017-07-24 13:44 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 13:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2017-07-13 05:29:02 EDT
Description of problem:

Having rawhide kernel packages installed I do this:

$ sudo dnf install kernel-4.11.9-200.fc25 --allowerasing
Last metadata expiration check: 0:04:21 ago on Thu Jul 13 10:21:04 2017.
Error: package kernel-4.11.9-200.fc25.x86_64 requires kernel-core-uname-r = 4.11.9-200.fc25.x86_64, but none of the providers can be installed

Which obviously is not true:

$ sudo dnf list kernel-*-4.11.9-200.fc25 --showduplicates
Last metadata expiration check: 0:07:14 ago on Thu Jul 13 10:21:04 2017.
Available Packages
kernel-PAE-devel.i686                                            4.11.9-200.fc25                                updates
kernel-PAEdebug-devel.i686                                       4.11.9-200.fc25                                updates
kernel-core.x86_64                                               4.11.9-200.fc25                                updates
kernel-cross-headers.x86_64                                      4.11.9-200.fc25                                updates
kernel-debug.x86_64                                              4.11.9-200.fc25                                updates
kernel-debug-core.x86_64                                         4.11.9-200.fc25                                updates
kernel-debug-devel.i686                                          4.11.9-200.fc25                                updates
kernel-debug-devel.x86_64                                        4.11.9-200.fc25                                updates
kernel-debug-modules.x86_64                                      4.11.9-200.fc25                                updates
kernel-debug-modules-extra.x86_64                                4.11.9-200.fc25                                updates
kernel-devel.x86_64                                              4.11.9-200.fc25                                updates
kernel-headers.x86_64                                            4.11.9-200.fc25                                updates
kernel-modules.x86_64                                            4.11.9-200.fc25                                updates
kernel-modules-extra.x86_64                                      4.11.9-200.fc25                                updates
kernel-tools.x86_64                                              4.11.9-200.fc25                                updates
kernel-tools-libs.i686                                           4.11.9-200.fc25                                updates
kernel-tools-libs.x86_64                                         4.11.9-200.fc25                                updates
kernel-tools-libs-devel.i686                                     4.11.9-200.fc25                                updates
kernel-tools-libs-devel.x86_64                                   4.11.9-200.fc25                                updates
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Mracek 2017-07-20 04:34:13 EDT
Please can you try to reproduce the problem with dnf-2.5+. It is available for rawhide, Fedora 26, or from our dnf-nightly repo for Fc24+ ("dnf copr enable rpmsoftwaremanagement/dnf-nightly")? 

If the problem is reproducible with dnf-2.5+ please provide:
1. Run it with --debugsolver option and provide debugsolver data
2. Provide /etc/dnf/dnf.conf
3. Please provide exact version of dnf, libdnf, libsolv (rpm -q <argumets>)
Comment 2 lejeczek 2017-07-22 03:51:44 EDT
In F26 I successfully installed: 
$ sudo dnf install kernel-4.11.10-300.fc26
and dnf did:
Removing:
 kernel                               x86_64                 4.12.0-0.rc0.git4.1.fc27                    @rawhide                   0  
 kernel-core                          x86_64                 4.12.0-0.rc0.git4.1.fc27                    @rawhide                  57 M
 kernel-modules                   

so I think it's good.
Comment 3 Jaroslav Mracek 2017-07-24 13:44:24 EDT
Thanks for your response and enjoy dnf-2.x

Note You need to log in before you can comment on or make changes to this bug.