Bug 147073 - Script errors from /etc/init.d/named
Summary: Script errors from /etc/init.d/named
Status: CLOSED DUPLICATE of bug 145664
Alias: None
Product: Fedora
Classification: Fedora
Component: bind   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-04 04:24 UTC by Garrett Schure
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Garrett Schure 2005-02-04 04:24:02 UTC
Description of problem:

/etc/init.d/named is giving script errors around the new
file ownership checking logic.

   Starting named: 
   /etc/init.d/named: line 49: [: : integer expression expected
   /etc/init.d/named: line 51: [: : integer expression expected

Also, my SELINUX setting of "disabled" is being ignored, at line 47.


Version-Release number of selected component (if applicable):
bind-9.2.4-8_FC3


Additional info:

My /etc/selinux/config settings:
SELINUX=disabled
SELINUXTYPE=strict

The file /etc/selinux/strict/booleans exists, and contains no
setting for named_write_master_zones.

Comment 1 Jason Vas Dias 2005-02-04 15:46:49 UTC
This is a known problem ( bug #145664 ) and will be fixed in the
next release of BIND for FC3 .
If you set SELINUXTYPE=targeted, the problem disappears.

*** This bug has been marked as a duplicate of 145664 ***

Comment 2 Jason Vas Dias 2005-02-25 19:59:38 UTC
This is now fixed in bind-9.2.5rc1-1 (FC3) / bind-9.3.1rc1-1 (FC4).



Comment 3 Red Hat Bugzilla 2006-02-21 19:08:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.