Bug 1470747 - fixing harmful typos in databases/mysql/general-changes/check
fixing harmful typos in databases/mysql/general-changes/check
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-el6toel7 (Show other bugs)
6.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Mazanek
Alois Mahdal
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 10:45 EDT by Jakub Mazanek
Modified: 2017-08-01 20:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: preupgrade-assistant-el6toel7-0.6.71-2.el6
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 20:10:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Mazanek 2017-07-13 10:45:25 EDT
Description of problem:
Backticks in place of single quotes caused module to hang, waiting for output of non-existing commands

Version-Release number of selected component (if applicable):
preupgrade-assistant-el6toel7-0.6.69-1.el6_8.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Fixed. Now the module works as expected
Comment 3 Alois Mahdal 2017-07-17 07:18:09 EDT
Notes for QA
============

This should reproduce the issue (according to info from @bnater, who originally reproduced it on in-place upgrade workshop).

    {
        echo 'DROP DATABASE php_mysql_test;'
        echo 'CREATE DATABASE php_mysql_test;'
        echo 'USE php_mysql_test;'
        echo 'CREATE TABLE foobar (name VARCHAR(10), value INTEGER);'
        echo 'INSERT INTO foobar VALUES("fish", 42);'
    } | mysql --verbose -u root
   preupg --force

...and preupg will get stuck at mysql module mysql/general_changes.

Also, make sure to review the patch:

    http://git.app.eng.bos.redhat.com/git/preupgrade-assistant-contents.git/commit/?h=rhel6_7-post&id=e91c3b4b452b8c194d350f81cd5d33c02573ef60
Comment 4 Alois Mahdal 2017-07-17 07:45:35 EDT
(Correcting Alois Mahdal's comment #3)
> Notes for QA
> ============
> 
> This should reproduce the issue (according to info from @bnater, who
> originally reproduced it on in-place upgrade workshop).


Of course, first:

    yum -y install mysql mysql-server
    service mysql start

...then:

>     {
>         echo 'DROP DATABASE php_mysql_test;'
>         echo 'CREATE DATABASE php_mysql_test;'
>         echo 'USE php_mysql_test;'
>         echo 'CREATE TABLE foobar (name VARCHAR(10), value INTEGER);'
>         echo 'INSERT INTO foobar VALUES("fish", 42);'
>     } | mysql --verbose -u root
>    preupg --force
Comment 5 Alois Mahdal 2017-07-17 15:24:21 EDT
Turns out that /CoreOS/preupgrade-assistant-el6toel7/upg/mysql-sanity reproduces this as well, so I used that instead of the above STR.

 *  TJ#1959725 preupgrade-assistant-el6toel7-0.6.70-2.el6 - is still
    stuck at the mysql module.

 *  TJ#1959724 preupgrade-assistant-el6toel7-0.6.71-2.el6 - has already
    finished and passed.

 *  I have reviewed the texts and terms are now quoted using apostrophes.

 *  I have also reviewed the patch -- looks OK.
Comment 7 errata-xmlrpc 2017-08-01 20:10:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2400

Note You need to log in before you can comment on or make changes to this bug.