Bug 147087 - RPM doesn't know about lib64?
RPM doesn't know about lib64?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 06:26 EST by Andrew Gormanly
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Gormanly 2005-02-04 06:26:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
RPM does not find 64-bit library files in its database.

The problem is exposed when rpm is invoked as e.g.

rpm -q --whatprovides libvorbisfile.so.3

but not when used as e.g.

rpm -qf /usr/lib64/libvorbisfile.so.3

32-bit files in /lib and /usr/lib are found normally however.

This breaks some software builds (here only xmms, but obviously will
affect others too).


Version-Release number of selected component (if applicable):
rpm-4.2.3-13

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --whatprovides libvorbisfile.so.3
2.
3.
    

Actual Results:  # rpm -q --whatprovides libvorbisfile.so.3
no package provides libvorbisfile.so.3


Expected Results:  # rpm -q --whatprovides libvorbisfile.so.3
libvorbis-1.0-7


Additional info:

The same command works normally on the 32-bit i386 version of RHEL3
(output on expected results is taken from such a machine).

I think this might be a failure to read entries in  Providename with
()(64bit) after the filename, e.g.

# strings /var/lib/rpm/Providename | grep vorbisfile
libvorbisfile.so.3()(64bit)

as entries those without it are found:

# strings /var/lib/rpm/Providename | grep libvorbis-devel
libvorbis-devel
# rpm -q --whatprovides libvorbis-devel
libvorbis-devel-1.0-7

This is only a guess, however, as I'm not an RPM expert...
Comment 1 Paul Nasrat 2005-11-28 15:53:07 EST
The provide names are seperate based on wordsize so for ELF64 you should do:

rpm --provides -q libvorbis.x86_64

rpm --whatprovides -q 'libvorbisfile.so.3()(64bit)'

Note You need to log in before you can comment on or make changes to this bug.