Bug 1470896 - segfault when reading vmap0
segfault when reading vmap0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ogdi (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 20:19 EDT by Thomas Sailer
Modified: 2017-08-02 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: ogdi-3.2.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 12:49:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ogdi compile and vrf bugfix (935 bytes, patch)
2017-07-13 20:19 EDT, Thomas Sailer
no flags Details | Diff

  None (edit)
Description Thomas Sailer 2017-07-13 20:19:31 EDT
Created attachment 1297992 [details]
ogdi compile and vrf bugfix

Description of problem:
when trying to read features from the vector map level 0 (vmap0) source, the program crashes within the ogdi vrf driver. Plus sprintf without format string fails the build

Version-Release number of selected component (if applicable):
3.2.0-0.28.beta2.fc26

How reproducible:
always


Additional info:
the attached patch fixes it for me
Comment 1 Dan Horák 2017-07-14 02:24:35 EDT
Hi Thomas, thanks for the patch, feel free to update the ogdi package, I took it when it was getting orphaned and removed and it affected my other package.
Comment 2 Dan Horák 2017-07-14 05:16:36 EDT
Oh, there seems to be an official 3.2.0 release since last year, we should update the Fedora package.
Comment 3 Dan Horák 2017-07-17 03:54:46 EDT
ABI diff between 3.2.0-beta2 and 3.2.0 final => it's safe to update

================ changes of 'libogdi.so.3.2'===============
  Functions changes summary: 0 Removed, 0 Changed, 3 Added functions
  Variables changes summary: 0 Removed, 0 Changed, 0 Added variable

  3 Added functions:

    'function int ecs_SetErrorShouldStop(ecs_Result*, int, char*)'    {ecs_SetErrorShouldStop}
    'function ReportErrorType ecs_SetReportErrorFunction(ReportErrorType)'    {ecs_SetReportErrorFunction}
    'function int ecs_ShouldStopOnError()'    {ecs_ShouldStopOnError}

================ end of changes of 'libogdi.so.3.2'===============
Comment 4 Fedora Update System 2017-07-17 09:12:43 EDT
ogdi-3.2.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-32f2436617
Comment 5 Fedora Update System 2017-07-17 20:24:25 EDT
ogdi-3.2.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-32f2436617
Comment 6 Fedora Update System 2017-08-02 12:49:18 EDT
ogdi-3.2.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.