Bug 147091 - wrong ordering with hungarian locale
Summary: wrong ordering with hungarian locale
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-04 12:16 UTC by Gyuro Lehel
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 15:27:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a diff file for the proposed modifications (1.36 KB, text/plain)
2005-02-04 12:25 UTC, Gyuro Lehel
no flags Details
patch file for a correctly working hungarian locale description file (2.15 KB, patch)
2005-02-07 13:03 UTC, Gyuro Lehel
no flags Details | Diff

Description Gyuro Lehel 2005-02-04 12:16:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
when using hungarian (either iso8859-2, or utf8) locale the collation
is done in a wrong way (for example when selecting and ordering a
varchar field from a table in postgresql). After some digging I found
out, that the root of the problem is in the collation rules defined in
the locale configuration file, which does not differentiate between
the plain and accented characters

Version-Release number of selected component (if applicable):
all

How reproducible:
Always

Steps to Reproduce:
try to sort any hungarian string
    

Actual Results:   �. A.
 Ab�di Nagy Zolt�n
 Acz�l Gy�rgy
 �cs P�l
 �cs Tam�s - Kiszely Gy�rgy
 �d�m Antal
 �d�m Gy�rgy
 �d�m L�szl�
 �d�m P�ter
 Ady Endre
 A. F.
 A. G.
 �gai �gnes
 A. Gergely Andr�s


Expected Results:   Ab�di Nagy Zolt�n
 Acz�l Gy�rgy
 Ady Endre
 A. F.
 A. G.
 A. Gergely Andr�s
 �. A.
 �cs P�l
 �cs Tam�s - Kiszely Gy�rgy
 �d�m Antal
 �d�m Gy�rgy
 �d�m L�szl�
 �d�m P�ter
 �gai �gnes


Additional info:

Comment 1 Gyuro Lehel 2005-02-04 12:25:38 UTC
Created attachment 110643 [details]
a diff file for the proposed modifications

a diff file for a modified hu_HU locale.
I compiled it with localedef -c -f /usr/share/i18n/charmaps/ISO-8859-2 -v -i
/usr/share/i18n/locales/hu_HU /usr/lib/locale/hu_HU
it seemed to be o.k. but even after reboot, and postgres reinitialization the
collation order was the same. Sorry if I was lame :).

Comment 2 Gyuro Lehel 2005-02-07 13:03:35 UTC
Created attachment 110716 [details]
patch file for a correctly working hungarian locale description file

working ordering for hungarian locale and accented characters


Note You need to log in before you can comment on or make changes to this bug.