Bug 147094 - autofs in U4 doesn't work on NIS mounts that did in U3!
autofs in U4 doesn't work on NIS mounts that did in U3!
Status: CLOSED DUPLICATE of bug 146887
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 07:45 EST by Richard Freeman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 10:33:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Freeman 2005-02-04 07:46:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
Basically, we've got autofs mounting some NIS home directories only.
For some reason, so U4 it periodically fails on some mounts and then
sometimes doesn't work at all!

When I try to mount it under U4, it simply says "no such file or
directory". If I manually mount the directory, then it works fine.
This affects both i386 & x86-64 from my tests. :(

e.g. On U3:

osno-cs06[214] ~ >   cat /etc/auto.master
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc  /etc/auto.misc --timeout=60
#/misc  /etc/auto.misc
#/net   /etc/auto.net

/home   yp:auto_home
osno-cs06[215] ~ >  rpm -qa | grep autofs
autofs-4.1.3-12
osno-cs06[216] ~ > ypcat auto_home | grep jlowther
-hard,bg,intr,rsize=8192,wsize=8192
bofs2a:/vol/bofs2avol3/HOME_IS/jlowther
osno-cs06[217] ~ > cd ~jlowther/
osno-cs06[218] ~jlowther > df -k .
Filesystem           1K-blocks      Used Available Use% Mounted on
bofs2a:/vol/bofs2avol3/HOME_IS/jlowther
                      20971520  17360256   3611264  83% /home/jlowther

But on U4!

osno-cs04[201] ~ >  cat /etc/auto.master
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc  /etc/auto.misc --timeout=60
#/misc  /etc/auto.misc
#/net   /etc/auto.net

/home   yp:auto_home
osno-cs04[202] ~ >  rpm -qa | grep autofs
autofs-4.1.3-47
osno-cs04[203] ~ >  ypcat auto_home | grep jlowther
-hard,bg,intr,rsize=8192,wsize=8192
bofs2a:/vol/bofs2avol3/HOME_IS/jlowther
osno-cs04[204] ~ >  cd ~jlowther/
/home/jlowther/: No such file or directory.

The messages log contains this:

Feb  4 12:43:13 osno-cs04 automount[3329]: failed to mount /home/jlowther

This is reproducable across all of our machines.

Version-Release number of selected component (if applicable):
autofs-4.1.3-47

How reproducible:
Always

Steps to Reproduce:
1. cd ~jlowther
2. Do anything!
3.
    

Actual Results:  The home directory cannot be found. :(

Expected Results:  The home directory would be mounted.

Additional info:

This is an important bug for us to be fixed, as it causes random
autofs failures across all of our systems it is causing some pain for us.
Comment 1 Richard Freeman 2005-02-04 09:31:32 EST
It should be noted for mounts on the "LAN" from the box, they work all
the time from what I can tell.

It is WAN'd mounts which are causing the problem. Although how autofs
knows this, I don't know. The further away the remote NFS host is, the
worse it gets. Sensitive to response times maybe?

Thanks,
Comment 2 Jeffrey Moyer 2005-02-04 10:13:08 EST
Thank you for adding that last bit.  I believe we have a fix for this in current
RPMs.  Could you try the RHEL 3 rpm found here:

  http://people.redhat.com/jmoyer/.bz147094/

If you need an x86_64 rpm, just let me know.

Thanks!
Comment 3 Richard Freeman 2005-02-04 10:27:52 EST
[root@osno-cs04 root]# /usr/sbin/automount --version
Linux automount version 4.1.3-91
[root@osno-cs04 root]# cd ~jlowther
[root@osno-cs04 jlowther]# df -k .
Filesystem           1K-blocks      Used Available Use% Mounted on
bofs2a:/vol/bofs2avol3/HOME_IS/jlowther
                      20971520  17360440   3611080  83% /home/jlowther

We have a winner! Yes, please supply the x86-64 version also.

Any idea when this is going to be released properly?

Thanks for the quick reply also. :)

Rich
Comment 4 Jeffrey Moyer 2005-02-04 10:33:45 EST
Okay, the x86_64 package has been uploaded.  Note that this is an unofficial
build.  The version of the fix you are using is not the final, either.  I may
ask you to try another package, if it is convenient for you.

This bug is a duplicate of another, so marking it as such.

-Jeff

*** This bug has been marked as a duplicate of 146887 ***
Comment 5 Richard Freeman 2005-02-04 10:40:16 EST
We can try another package, that'll be no problem at all to help out.

Question - could we use autofs from U3 instead with U4 to resolve the issue?

Thanks Jeff!

Rich

Comment 6 Jeffrey Moyer 2005-02-04 10:50:06 EST
Yes, if the version from U3 works for you, it is quite acceptable to continue
using it.

Note You need to log in before you can comment on or make changes to this bug.