Bug 1470966 - NetworkManager - wrong interpretation of DHCP option
NetworkManager - wrong interpretation of DHCP option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
26
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Reopened
: 1455557 1469786 1473423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 03:22 EDT by Antonin
Modified: 2017-07-25 10:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: NetworkManager-1.8.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 11:54:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin 2017-07-14 03:22:33 EDT
Description of problem:

After upgrading to Fedora 26 I get on my pc (DHCP client) wrong domain list defined in "search" option on my DHCP server.

/etc/resolv.conf on pc with hostname "pc1.home":
    # Generated by NetworkManager
    search pc1.home
    nameserver 192.168.0.1

/etc/dhcp/dhcpd.conf on my DHCP server:
    option domain-name "home";


Version-Release number of selected component (if applicable):

NetworkManager.x86_64  1:1.8.0-6.fc26


How reproducible:

Use DHCP server with defined "search" option.


Actual results:

/etc/resolv.conf:
    search pc1.home


Expected results:

/etc/resolv.conf:
    search home
Comment 1 Beniamino Galvani 2017-07-17 04:31:08 EDT

*** This bug has been marked as a duplicate of bug 1404350 ***
Comment 2 Beniamino Galvani 2017-07-18 07:50:31 EDT
Unduplicating, the other bug is for F25.
Comment 3 Fedora Update System 2017-07-18 07:52:23 EDT
NetworkManager-1.8.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8949032ca5
Comment 4 Fedora Update System 2017-07-19 20:25:53 EDT
NetworkManager-1.8.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8949032ca5
Comment 5 Beniamino Galvani 2017-07-20 03:08:03 EDT
*** Bug 1455557 has been marked as a duplicate of this bug. ***
Comment 6 Beniamino Galvani 2017-07-20 03:08:40 EDT
*** Bug 1469786 has been marked as a duplicate of this bug. ***
Comment 7 Werner Gold 2017-07-20 06:30:24 EDT
After the update, the search parameter now does contain
search <domain> <hostname>.<domain>
Although that effectively solves the problem, I am not sure, why <hostname>.<domain> is still in. What is its purpose?
Comment 8 Fedora Update System 2017-07-20 11:54:07 EDT
NetworkManager-1.8.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Beniamino Galvani 2017-07-21 09:18:09 EDT
(In reply to Werner Gold from comment #7)
> After the update, the search parameter now does contain
> search <domain> <hostname>.<domain>
> Although that effectively solves the problem, I am not sure, why
> <hostname>.<domain> is still in. What is its purpose?

Hi,

the purpose is explained here:

https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/src/dns/nm-dns-manager.c?h=nm-1-8&id=1.8.2#n1045
Comment 10 Beniamino Galvani 2017-07-25 10:35:11 EDT
*** Bug 1473423 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.