Bug 1470971 - Unable to use the Bitstream Charter font (installed in /usr/share/X11/fonts/Type1) in some LO document
Unable to use the Bitstream Charter font (installed in /usr/share/X11/fonts/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 03:28 EDT by Joachim Backes
Modified: 2017-07-14 04:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 03:49:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2017-07-14 03:28:18 EDT
Description of problem:
I'm trying to use the Bitstream Charter in a new LO document (indepently from odt/odp/odg), but it is not listed in LO from the available fonts.

On The other hand, abiword offers Bitstream Charter for usage, and I can format some text into Bitstream Charter.

If running fc-list,  I find Bitstream Charter:

fc-list|grep -i charter
/usr/share/X11/fonts/Type1/c0648bt_.pfb: Bitstream Charter:style=Regular
/usr/share/X11/fonts/Type1/c0633bt_.pfb: Bitstream Charter:style=Bold Italic
/usr/share/X11/fonts/Type1/c0649bt_.pfb: Bitstream Charter:style=Italic
/usr/share/X11/fonts/Type1/c0632bt_.pfb: Bitstream Charter:style=Bold

But nothing /usr/share/fonts is not listed.

It seems LO does not use /usr/share/X11/fonts/Type1, but abiword seems to do.

Version-Release number of selected component (if applicable):

libreoffice-5.3.4.2-3.fc26.x86_64
How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.

Actual results:


Expected results:


Additional info:

Copying /usr/share/X11/fonts to  ~/.fonts  (and then running fc-cache) does not help
Comment 1 Caolan McNamara 2017-07-14 03:49:09 EDT
https://wiki.documentfoundation.org/ReleaseNotes/5.3
Support for Type 1 fonts has been removed (Khaled Hosny) commit 48304cb (https://cgit.freedesktop.org/libreoffice/core/commit/?id=48304cb5b4d8df71463837e2e48aa7c4d9594df9)
Comment 2 Joachim Backes 2017-07-14 04:28:44 EDT
It cannot be that I have to convert all concerned Type1 fonts to the fitting format :-(

Or do you know a better solution?

Note You need to log in before you can comment on or make changes to this bug.