Bug 1470978 - When add environment variable using a config map or secret and click select a resource drop-sown menu, page show blank in iPad Pro & iPhone Safari.
When add environment variable using a config map or secret and click select a...
Status: CLOSED WORKSFORME
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Robb Hamilton
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 03:52 EDT by xipang
Modified: 2018-02-06 00:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-06 00:51:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
show blank page (32.20 KB, image/png)
2017-07-14 03:52 EDT, xipang
no flags Details
Working dropdown (185.57 KB, image/png)
2017-07-16 08:11 EDT, Samuel Padgett
no flags Details

  None (edit)
Description xipang 2017-07-14 03:52:47 EDT
Created attachment 1298162 [details]
show blank page

Description of problem:
When add environment variable using a config map or secret and click select a resource  drop-sown menu, page show blank in iPad Pro & iPhone Safari.

Version-Release number of selected component (if applicable):
openshift v3.6.144
kubernetes v1.6.1+5115d708d7

How reproducible:
Always

Steps to Reproduce:
1. Create resources
$ oc new-app https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json

Create a configmap:

cat >>configmap <<-EOF
apiVersion: v1
kind: ConfigMap
metadata:
  name: special-config
data:
  special.how: very
  special.type: charm
EOF

2.From web consonsole, set env variables for DC/database.
2.1 clicking "Add Environment Variable Using a Config Map or Secret" from Environment twice
2.2 input Name "my_configmap", select "special-config" and "special.how" from Value

Actual results:
2.2 When click select a resource drop-dwon menu , page show blank.

Expected results:
2.2 Page does not show blank.

Additional info:
Comment 1 Samuel Padgett 2017-07-16 08:11 EDT
Created attachment 1299319 [details]
Working dropdown

I haven't been able to reproduce following the steps in the description.
Comment 2 Samuel Padgett 2017-07-16 08:12:13 EDT
What iOS version are you using? It happens always on both iPad and iPhone?
Comment 3 xipang 2017-07-17 02:40:18 EDT
(In reply to Samuel Padgett from comment #2)
> What iOS version are you using? It happens always on both iPad and iPhone?

iOS 10.0
when i check again, the bug didn't happen in iPhone.
But It still always happens in the iPad Pro.
Comment 4 Samuel Padgett 2017-07-17 08:31:21 EDT
I can reproduce on iPad (12.9 inch, second generation) and iOS 10.3. This feels like it might be an iOS Safari bug. Desktop Safari does not have the problem.
Comment 5 xipang 2017-07-17 21:26:33 EDT
(In reply to Samuel Padgett from comment #4)
> I can reproduce on iPad (12.9 inch, second generation) and iOS 10.3. This
> feels like it might be an iOS Safari bug. Desktop Safari does not have the
> problem.

Yeah, I think so.
Desktop Safari did not have the problem.The problem is only about iOS Safari.
Comment 6 Robb Hamilton 2018-01-18 16:22:11 EST
I am unable to reproduce using iOS 11.2, which is what we now support since we only support the latest version of iOS.  

xipang, can you reproduce using iOS 11.2?  If not, I think spadgett is probably correct and this was mobile Safari issue in iOS 10.x.
Comment 7 yapei 2018-02-06 00:41:20 EST
iOS 11.2(both iPhone and iPad) doesn't reproduce the issue now.
Comment 8 yapei 2018-02-06 00:51:03 EST
Close the bug since it works now

Note You need to log in before you can comment on or make changes to this bug.