Bug 1470983 - [Ganesha] Path to export configuration is outdated
[Ganesha] Path to export configuration is outdated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Laura Bailey
Manisha Saini
:
Depends On:
Blocks: 1417157
  Show dependency treegraph
 
Reported: 2017-07-14 04:22 EDT by Chris Blum
Modified: 2017-09-21 00:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:27:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Blum 2017-07-14 04:22:54 EDT
Document URL: 
https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.2/html/administration_guide/sect-nfs#sect-NFS_Ganesha

Section Number and Name: 
6.2.4.5. MODIFYING THE HA CLUSTER USING THE GANESHA-HA.SH SCRIPT
Modifying the default export configuration

Describe the issue: 
The text states:
"Edit/add the required fields in the corresponding export file located at /etc/ganesha/exports/."

But since RHGS 3.2.0 these exports are now based on the gluster_shared_storage volume. So the correct path would be:
/run/gluster/shared_storage/nfs-ganesha/exports
Comment 3 Manisha Saini 2017-09-01 00:54:13 EDT
Laura,

Verified the section -6.2.3.5. Modifying the Default Export Configurations
Changes looks good to me.


Little Change is needed in section "6.2.3.9. Manually Configuring NFS-Ganesha Exports" as well


1.Edit/add the required fields in the corresponding export file located at /etc/ganesha/exports/.
2.Execute the following command

In 1st point instead of /etc/ganesha/exports/ ,replace it with the changed path - /run/gluster/shared_storage/nfs-ganesha/exports

Moving it to assigned state to incorporate he requested changes

Thanks
Comment 5 Manisha Saini 2017-09-05 07:24:33 EDT
Changes looks good to me.Moving this bug to verified state.

Note You need to log in before you can comment on or make changes to this bug.