Bug 1471042 - Ceph - rbdmap systemd unit file has missing [INSTALL] section in ceph-common-10.2.3-17.el7cp.x86_64.rpm
Ceph - rbdmap systemd unit file has missing [INSTALL] section in ceph-common-...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
2.3
x86_64 Linux
medium Severity medium
: rc
: 3.0
Assigned To: Jason Dillaman
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 06:00 EDT by Ashish Singh
Modified: 2017-07-30 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 08:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Singh 2017-07-14 06:00:36 EDT
* Description of problem:
rbdmap systemd unit file doesn't contains the [INSTALL] section in '/usr/lib/systemd/system/rbdmap.service' in ceph-common-10.2.3-17.el7cp.x86_64.rpm.

$ cat ./usr/lib/systemd/system/rbdmap.service
[Unit]
Description=Map RBD devices

After=network-online.target local-fs.target
Wants=network-online.target local-fs.target

[Service]
EnvironmentFile=-/etc/sysconfig/ceph
Environment=RBDMAPFILE=/etc/ceph/rbdmap
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/rbdmap map
ExecReload=/usr/bin/rbdmap map
ExecStop=/usr/bin/rbdmap unmap

Because of this, `systemctl is-enabled rbdmap` gives output as "static".
And this leads to, rbd images not getting automount-ed after boot as 'rbdmap.service' is not enabled.

* Version-Release number of selected component (if applicable):
ceph-common-10.2.3-17.el7cp.x86_64.rpm
ceph-common-10.2.3-13.el7cp.x86_64.rpm
ceph-common-10.2.2-38.el7cp.x86_64.rpm


* How reproducible:
Always


* Steps to Reproduce:
1. /* Under description */


* Actual results:
After enabling 'rbdmap', rbd images are not getting auto-mounted after boot.


* Expected results:
After enabling 'rbdmap', rbd images should be auto-mounted after boot.


* Additional info:
Workaround is to manually create a link to 'rbdmap.service' from the target.
# ln -s /usr/lib/systemd/system/rbdmap.service /etc/systemd/system/multi-user.target.wants/rbdmap.service
Comment 3 Ashish Singh 2017-07-17 08:58:24 EDT
Fixed in 2.2.

Note You need to log in before you can comment on or make changes to this bug.