Bug 147112 - rpm warnings during freshen of gnome-panel
rpm warnings during freshen of gnome-panel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 09:26 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.9.90-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 04:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-02-04 09:26:06 EST
Description of problem:
rpm warnings during freshen of gnome-panel


Version-Release number of selected component (if applicable):
gnome-panel-2.9.90-2

How reproducible:
100%

Steps to Reproduce:
1.rpm -Uvh --replacepkgs gnome-panel-2.9.90-2.i386.rpm
2.
3.
  
Actual results:
root@penguin:fc-devel# rpm -Uvh --replacepkgs
gnome-panel-2.9.90-2.i386.rpm
Preparing...               
########################################### [100%]
   1:gnome-panel           
########################################### [100%]
I/O warning : failed to load external entity
"/etc/gconf/schemas/gnome-panel-screenshot.schemas"
Failed to open `/etc/gconf/schemas/gnome-panel-screenshot.schemas': No
such file or directory
WARNING: Failed to parse default value `Û²Û´' for schema
(/schemas/apps/clock_applet/prefs/hour_format)
WARNING: Failed to parse default value `२४' for schema
(/schemas/apps/clock_applet/prefs/hour_format)
WARNING: Failed to parse default value `୨୪' for schema
(/schemas/apps/clock_applet/prefs/hour_format)
root@penguin:fc-devel#

Expected results:
no warnings

Additional info:
Comment 1 Mark McLoughlin 2005-02-04 11:19:40 EST
Should be fixed in 2.9.90-3 which is on the way
Comment 2 Michal Jaegermann 2005-02-05 18:39:29 EST
> Should be fixed in 2.9.90-3 ...
With gnome-panel-2.9.90-3 I see not only all the above but also

Document `/etc/gconf/schemas/panel-default-setup-battstat.entries' has
the wrong type of root node (<gconfentryfile>, should be
<gconfschemafile>)
Document `/etc/gconf/schemas/panel-default-setup.entries' has the
wrong type of root node (<gconfentryfile>, should be <gconfschemafile>)

which is something new.
Comment 3 Mark McLoughlin 2005-02-07 04:56:25 EST
Thanks, committed this:

* Mon Feb  7 2005 Mark McLoughlin <markmc@redhat.com> - 2.9.90-4
- Don't use --makefile-install-rule to install .entries files (#147112)

So, the current state is:

  - "Failed to load gnome-panel-screenshot.schemas" is fixed

  - "panel-default-setup-battstat.entries has the wrong type" is
    fixed

  - "WARNING: Failed to parse default value" has been fixed upstream
    and will be in 2.9.91. See bug #119956

Please open new bug reports for anything else.

Note You need to log in before you can comment on or make changes to this bug.