Bug 1471147 - mock randomly hangs with i686 environment
mock randomly hangs with i686 environment
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 10:01 EDT by Martin
Modified: 2017-08-09 04:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 04:07:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2017-07-14 10:01:53 EDT
Description of problem:
mock randomly hangs, not every time on same place.

Version-Release number of selected component (if applicable):
mock-1.4.2-1.fc26.noarch

dnf-plugins-core-2.1.2-2.fc26.noarch
dnf-2.5.1-1.fc26.noarch
distribution-gpg-keys-1.11-1.fc26.noarch
coreutils-8.27-5.fc26.x86_64
procps-ng-3.3.10-13.fc26.x86_64
systemd-233-6.fc26.x86_64
usermode-1.111-9.fc26.x86_64
tar-1.29-4.fc26.x86_64
python3-3.6.1-8.fc26.x86_64
pigz-2.3.4-2.fc26.x86_64
systemd-container-233-6.fc26.x86_64
util-linux-2.30-1.fc26.x86_64
shadow-utils-4.3.1-3.fc26.x86_64
createrepo_c-0.10.0-9.fc26.x86_64

How reproducible:
try build some package


Steps to Reproduce:
1.mock -r fedora-26-i386 --rebuild package.src.rpm
2.mock hangs (randomly)


Actual results:
mock i686 build hangs

Expected results:
mock works ok

Additional info:
x86_64 build works
Comment 1 Miroslav Suchý 2017-07-31 04:57:58 EDT
Does this happen only with one src.rpm or it happened with various packages?

Can you provide log with `mock --trace -vvv`?
Comment 2 Martin 2017-08-07 11:34:11 EDT
will happend with every package,but only after when some build fails ,deleting /var/cache/mock fix this.(mock --clean not help)


after some updates, this not happing.
Im not able to reproduce again

looks works ok now.
Comment 3 Miroslav Suchý 2017-08-09 04:07:08 EDT
OK. Please reopen if it would happened again.

Note You need to log in before you can comment on or make changes to this bug.