This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471153 - RFE: provide cmake-filesystem
RFE: provide cmake-filesystem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 10:18 EDT by Rex Dieter
Modified: 2017-07-31 15:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: cmake-3.9.0-1.fc26 cmake-3.9.0-1.fc25 cmake-3.9.0-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 15:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2017-07-14 10:18:08 EDT
Seems a fair number of -devel packages currently
Requires: cmake
for the sole purpose of dir ownership of %datadir/cmake or %libdir/cmake, and this seems to not wanted (by users) in some cases

Of course, packages are free to avoid the dep by owning the dir themselves.

Another possibility is a hybrid compomise of providing a lightweight 'cmake-filesystem' pkg that packages can depend on instead.

Thoughts?
Comment 1 Igor Gnatenko 2017-07-14 10:50:32 EDT
It's just not nice in packages to see:
%dir %{_datadir}/cmake
%dir %{_datadir}/cmake/Modules
%{_datadir}/cmake/Modules/FindLibSolv.cmake

because everyone should do it that way (apart from packages which are useless without cmake)
Comment 2 Orion Poplawski 2017-07-14 10:57:50 EDT
cmake-filesystem sounds good to me.
Comment 3 Fedora Update System 2017-07-19 08:48:07 EDT
cmake-3.9.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-43d35a1d73
Comment 4 Fedora Update System 2017-07-19 08:48:20 EDT
cmake-3.9.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-21a4cd85e8
Comment 5 Fedora Update System 2017-07-19 20:26:59 EDT
cmake-3.9.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-21a4cd85e8
Comment 6 Fedora Update System 2017-07-20 02:19:43 EDT
cmake-3.9.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5f2f2e4e4
Comment 7 Fedora Update System 2017-07-20 02:53:21 EDT
cmake-3.9.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-43d35a1d73
Comment 8 Fedora Update System 2017-07-22 23:57:40 EDT
cmake-3.9.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2017-07-23 18:55:47 EDT
cmake-3.9.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2017-07-24 04:30:55 EDT
cmake-3.9.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5f2f2e4e4
Comment 11 Kevin Kofler 2017-07-24 20:11:06 EDT
I think that this is unhelpful, switching to Requires: cmake-filesystem is going to make many packages fail to build because cmake is no longer implicitly dragged in as a transitive BR (and Igor Gnatenko's hack from comment #1 is even worse, multi-owned directories suck). Packages installing cmake configs should just Require cmake. Packages installing pkg-config configs even AUTOMATICALLY require pkg-config these days due to the pkg-config dependency generator. So why do we need to treat cmake differently?
Comment 12 Fedora Update System 2017-07-24 21:51:40 EDT
cmake-3.9.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5f2f2e4e4
Comment 13 Fedora Update System 2017-07-31 15:18:34 EDT
cmake-3.9.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.