Bug 1471178 - virt-manager refusing to launch. Producing python error message.
virt-manager refusing to launch. Producing python error message.
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 11:14 EDT by Jakub Sycha
Modified: 2017-07-16 17:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 12:13:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Sycha 2017-07-14 11:14:07 EDT
Description of problem:

When I run virt-manager, it does not launch and I get presented with the following error message:

> Traceback (most recent call last):
>  File "/usr/share/virt-manager/virt-manager", line 33, in <module>
>    from virtinst import util as util
>  File "/usr/share/virt-manager/virtinst/__init__.py", line 89, in <module>
>    from virtinst.distroinstaller import DistroInstaller
>  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 23, in <module>
>    from . import urlfetcher
>  File "/usr/share/virt-manager/virtinst/urlfetcher.py", line 34, in <module>
>    import requests
>  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 60, in <module>
>    from .packages.urllib3.exceptions import DependencyWarning
>  File "/usr/lib/python2.7/site-packages/requests/packages/__init__.py", line 29, in <module>
>    import urllib3
>  File "/usr/lib/python2.7/site-packages/urllib3/__init__.py", line 8, in <module>
>    from .connectionpool import (
>  File "/usr/lib/python2.7/site-packages/urllib3/connectionpool.py", line 39, in <module>
>    from .util.request import set_file_position
> ImportError: cannot import name set_file_position



Version-Release number of selected component (if applicable): Seems to be "1.4.1-2.fc26"


How reproducible: N/A


Steps to Reproduce:
1. dnf install virt-manager (on Fedora 26)
2. virt-manager
3. Profit...

Actual results: Error message


Expected results: virt-manager should start


Additional info:

Fedora 26 (4.11.9-300.fc26.x86_64)
Comment 1 Cole Robinson 2017-07-14 12:13:11 EDT
This is very likely to do with multiple installed but conflicting versions of python urllib3 or python requests. See my comments on this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1459100

I'm closing since I'm nearly positive this is not a virt-manager issue, not impossible you'll need to file a urllib3 or requests bug though
Comment 2 Jakub Sycha 2017-07-16 11:44:19 EDT
I'm afraid I don't have access to the linked bug.
Comment 3 Cole Robinson 2017-07-16 17:34:09 EDT
Sorry about that, I've opened it up now

Note You need to log in before you can comment on or make changes to this bug.