Bug 1471333 - [abrt] clinfo: llvm::cast<llvm::CompositeType, llvm::Type>(): clinfo killed by signal 6
[abrt] clinfo: llvm::cast<llvm::CompositeType, llvm::Type>(): clinfo killed b...
Status: CLOSED DUPLICATE of bug 1458595
Product: Fedora
Classification: Fedora
Component: clinfo (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:08a423c2005e8b1f00ff1aca840...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 23:24 EDT by maarten
Modified: 2017-07-15 04:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-15 04:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.32 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: cgroup (355 bytes, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: core_backtrace (10.00 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: cpuinfo (1.20 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: dso_list (5.35 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: environ (3.47 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: limits (1.29 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: maps (25.43 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: open_fds (498 bytes, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details
File: var_log_messages (303 bytes, text/plain)
2017-07-14 23:24 EDT, maarten
no flags Details

  None (edit)
Description maarten 2017-07-14 23:24:05 EDT
Description of problem:
Executed clinfo in the console:
$ clinfo
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
X server found. dri2 connection failed! 
clinfo: /usr/include/llvm/Support/Casting.h:236: typename llvm::cast_retty<X, Y*>::ret_type llvm::cast(Y*) [with X = llvm::CompositeType; Y = llvm::Type; typename llvm::cast_retty<X, Y*>::ret_type = llvm::CompositeType*]: Assertion `isa<X>(Val) && "cast<Ty>() argument of incompatible type!"' failed.
Aborted (core dumped)
$ echo $?
134

Version-Release number of selected component:
clinfo-2.1.17.02.09-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        clinfo
crash_function: llvm::cast<llvm::CompositeType, llvm::Type>
executable:     /usr/bin/clinfo
journald_cursor: s=526dba4dfab74d48bf025c6e37ce79e5;i=4b2fc;b=0866ac36ce4f4a919e2f50126e34a875;m=ed5dd4c75;t=55452948b7619;x=420ace82872c8a75
kernel:         4.11.9-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 1 maarten 2017-07-14 23:24:12 EDT
Created attachment 1298745 [details]
File: backtrace
Comment 2 maarten 2017-07-14 23:24:13 EDT
Created attachment 1298746 [details]
File: cgroup
Comment 3 maarten 2017-07-14 23:24:15 EDT
Created attachment 1298747 [details]
File: core_backtrace
Comment 4 maarten 2017-07-14 23:24:17 EDT
Created attachment 1298748 [details]
File: cpuinfo
Comment 5 maarten 2017-07-14 23:24:18 EDT
Created attachment 1298749 [details]
File: dso_list
Comment 6 maarten 2017-07-14 23:24:20 EDT
Created attachment 1298750 [details]
File: environ
Comment 7 maarten 2017-07-14 23:24:21 EDT
Created attachment 1298751 [details]
File: limits
Comment 8 maarten 2017-07-14 23:24:23 EDT
Created attachment 1298752 [details]
File: maps
Comment 9 maarten 2017-07-14 23:24:25 EDT
Created attachment 1298753 [details]
File: open_fds
Comment 10 maarten 2017-07-14 23:24:26 EDT
Created attachment 1298754 [details]
File: proc_pid_status
Comment 11 maarten 2017-07-14 23:24:27 EDT
Created attachment 1298755 [details]
File: var_log_messages
Comment 12 maarten 2017-07-14 23:34:11 EDT
The problem is not local to clinfo:

Alternative reproducer, identical output to console:

# sudo dnf install ocl-icd-devel
$ pip3 install --user pyopencl
$ python3 -c "import pyopencl;pyopencl.get_platforms()"
Comment 13 Igor Gnatenko 2017-07-15 04:04:27 EDT

*** This bug has been marked as a duplicate of bug 1458595 ***

Note You need to log in before you can comment on or make changes to this bug.