Bug 1471409 - [RFE] Change default setting from NO to YES for Satellite 6.x Tools Repository in PRODUCT CONTENT tab in ACTIVATION KEY (repo required by bootstrap.py)
[RFE] Change default setting from NO to YES for Satellite 6.x Tools Repositor...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys (Show other bugs)
6.2.10
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-15 13:11 EDT by Reartes Guillermo
Modified: 2017-08-10 16:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 16:20:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2017-07-15 13:11:50 EDT
Description of problem:

The default for the Satellite 6.2 Tools repository in PRODUCT CONTENT in ACTIVATION KEY is NO

On some circumstances when any *VDC subscription is used and one tries to override the Satellite 6.2 Tools repository enabled status to YES, it will
not be possible because the repository will not be listed in PRODUCT CONTENT tab and will remain in NO.

Since one CANNOT add an "0 of unlimited subscription for an hypervisor" at that point in that case (because these subscriptions are not yet dynamically created), one cannot set the Satellite 6.2 Tools repository to override to YES. 

And if one uses the bootstrap.py because puppet is being used (and also to install the katello agent itself), the bootstrap.py will fail.

This would not be an issue if the "0 of unlimited subscription for an hypervisor" subscription were created at the time Sat6 receives and creates the content host for that hypvervisor.

ALTERNATIVE:
I believe that either the default for the Sat 6.x Tools repo in product content is changed to YES or Sat6 needs to create the "0 of unlimited subscription for an hypervisor" for each virt-who content hosts it creates, even if there is no known content host running at hat hypervisor YET.
And only evaluate compliance when there is at least 1 content host on an hypervisor. If there are 0 content hosts on an hypervisor... it is compliant. But the subscription needed for the activation key does not yet exists, it seems to be created only after there is at least 1 content host on that hypervisor.


Thanks in advance.

Version-Release number of selected component (if applicable):
6.2.10

How reproducible:
always

Steps to Reproduce:

01 - Customer will use puppet so it needs hosts groups.
02 - Customer will use the bootstrap.py due to using puppet. (and the bootstrap.py does other useful tasks too).

03 - Customer is using any *VDC subscriptions. 
04 - The virt-who service is configured and had reported its hypervisors to the Satellite 6.2 instance.
05 - The virt-who entries had already been created in the Satellite 6.2 instance.
06 - There are no content host yet registered to any of the virt-who entries already existing in the Satellite 6.2 instance.
07 - There is a mix of subscription on the Satellite (*VDC and non VDC), auto attach selects the non-vdc for content host on that hypervisor (before at least  1 content host is known to run on a hypervisor (and is GREEN) or one goes manually to the content hosts subscriptions tab and select "add" tab --hat causes the spinner to show, and it seems to trigger something that creates the subscription-, after that auto attach will select vdc on that hypervisor.

08 - try Create an activation key
09 - Go to add subscription, there are no "0 of unlimited subscription for an hypervisor" subscriptions to select for any host at this time.

10 - Go to PRODUCT CONTENT and try to enable the Satellite 6.2 Tools repository. It will not appear and it will not be possible to change the NO default.

11 - The bootstrap.py script will fail with this activation key, since the bootstrap.py will not be able to install puppet agent, katello agent, etc.


Actual results:
With this default for "Satellite 6.2 Tools repository" , one has to perform some workaround to force the existence of at least 1 "n of unlimited subscription for an hypervisor" subscription before attempting to create an activation key that will be used by the bootstrap.py script.
After that, it will be possible to configure the activation key's Satellite 6.2 Tools repository default to OVERRIDE TO YES. But not before.

Expected results:
It should be easy to use the bootstrap.py script with any *VDC subscriptions.

Additional info:
Additional info #1: 

In Sat6.2 Host Configuration Guide:

10.6.2. 

 Installing the Katello Agent
   Prerequisites
   Satellite version 6.1 and later require that you enable the Satellite Tools repository.
   The Satellite Tools repository must be enabled, synchronized to the Red Hat Satellite Server and made available to your hosts as it provides the required packages. 

Additional info #2: 

In Sat6.2 Host Configuration Guide:

10.6.3.
 Installing and Configuring the Puppet Agent
 Prerequisites
   Satellite version 6.1 and later require that you enable the Satellite Tools repository.
 The Satellite Tools repository must be enabled, synchronized to the Red Hat Satellite Server and made available to your hosts as it provides the required packages. 

Additional info #3: 

In Sat6.2 Puppet Guide:

3.6.
 Publishing a Content View
  9. Add the required Red Hat Enterprise Linux repositories, including a base Red Hat Enterprise Linux Server RPM collection and a Red Hat Satellite Tools RPM collection for the same version. The Tools RPM collection contains the packages to set up our remote Puppet configuration on provisioned systems.
Comment 2 Bryan Kearney 2017-08-10 16:20:40 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.