Bug 1471457 - usb and pci redirection don't work in xen
usb and pci redirection don't work in xen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
26
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-15 22:48 EDT by nucleo
Modified: 2017-09-11 14:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 14:41:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2017-07-15 22:48:48 EDT
Description of problem:
usb and redirection don't work in xen.

Version-Release number of selected component (if applicable):
qemu-system-x86-2.9.0-1.fc26.1.x86_64
xen-4.8.1-4.fc26.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Add in xen config xl.cfg setting like "pci = [ '01:23.4' ]" or "usbctrl = [ 'version=2' ]"
2. start domU
3.

Actual results:
libxl: error: libxl_qmp.c:287:qmp_handle_error_response: received an error message from QMP server: Unsupported bus. Bus doesn't have property 'acpi-pcihp-bsel' set
libxl: error: libxl_create.c:1461:domcreate_attach_devices: unable to add usbctrl devices
libxl: error: libxl.c:1575:libxl__destroy_domid: non-existant domain 12
libxl: error: libxl.c:1534:domain_destroy_callback: unable to destroy guest with domid 12
libxl: error: libxl.c:1463:domain_destroy_cb: destruction of domain 12 failed

or

libxl: error: libxl_qmp.c:287:qmp_handle_error_response: received an error message from QMP server: Unsupported bus. Bus doesn't have property 'acpi-pcihp-bsel' set
libxl: error: libxl_pci.c:1304:libxl__add_pcidevs: libxl_device_pci_add failed: -3
libxl: error: libxl_create.c:1461:domcreate_attach_devices: unable to add pci devices
libxl: error: libxl.c:1575:libxl__destroy_domid: non-existant domain 13
libxl: error: libxl.c:1534:domain_destroy_callback: unable to destroy guest with domid 13
libxl: error: libxl.c:1463:domain_destroy_cb: destruction of domain 13 failed


Additional info:
After downgrading to qemu-system-x86-2.8.0-2.fc26.x86_64 redirections works.
Comment 1 nucleo 2017-07-20 18:10:04 EDT
I don't know what causes this bug.

I assigned it to qemu because downgrading to qemu 2.8.0 fixes bug but maybe this bug should be fixed in xen? Then it should be reassigned to xen.
Comment 2 nucleo 2017-09-10 06:16:53 EDT
Updating qemu from 2.9.0-5.fc26 to 2.9.1-1.fc26 fixes redirection.
Comment 3 Cole Robinson 2017-09-11 14:41:08 EDT
Good to hear, thanks for confirming. Closing this then since 2.9.1 is heading for stable

Note You need to log in before you can comment on or make changes to this bug.