Bug 1471503 - Missing entry in virNetworkUpdateFlags documentation
Missing entry in virNetworkUpdateFlags documentation
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-16 09:28 EDT by Onmeac
Modified: 2017-07-16 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-16 12:56:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Onmeac 2017-07-16 09:28:58 EDT
Libvirt documentation is missing an entry under virNetworkUpdateFlags.

Current options:
VIR_NETWORK_UPDATE_AFFECT_CURRENT = 0
VIR_NETWORK_UPDATE_AFFECT_LIVE = 1
VIR_NETWORK_UPDATE_AFFECT_CONFIG = 2

A fourth one is missing:
<name> = 3
For updating both live and config.
Comment 1 Laine Stump 2017-07-16 12:56:06 EDT
the values of the enum virNetworkUpdateFlags are eash a single bit, and are intended to be bitwise-ORed together. This is already stated in the places where an API has a flags argument that uses virNetworkUpdateFlags. For example, this is what it says in the documentation for the virNetworkUpdate() function:

  flags:   bitwise OR of virNetworkUpdateFlags.

So if you want the update to affect both the live state of the network and the persistent config, you would send

   VIR_NETWORK_UPDATE_AFFECT_LIVE | VIR_NETWORK_UPDATE_AFFECT_CONFIG

The documentation for enums is auto-generated a single line is automatically generated for each enum value; there is no provision for adding extra lines to document combinations of values.

Note You need to log in before you can comment on or make changes to this bug.