Bug 1471515 - [abrt] gnome-software: _pkgdb_item_free(): gnome-software killed by signal 6
[abrt] gnome-software: _pkgdb_item_free(): gnome-software killed by signal 6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
27
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:7919e7701455d1d529de204cbf8...
:
: 1496898 1497626 1497810 1507016 1514619 1516106 1516400 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-16 11:11 EDT by Chris Murphy
Modified: 2017-11-22 09:40 EST (History)
18 users (show)

See Also:
Fixed In Version: gnome-software-3.26.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-21 10:36:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (74.11 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: cgroup (210 bytes, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: core_backtrace (45.45 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: cpuinfo (1.12 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: dso_list (18.70 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: environ (1.75 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: limits (1.29 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: maps (89.59 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: open_fds (4.21 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
File: var_log_messages (14.50 KB, text/plain)
2017-07-16 11:11 EDT, Chris Murphy
no flags Details
journal.log (23.35 KB, text/plain)
2017-07-16 11:23 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2017-07-16 11:11:08 EDT
Description of problem:
Crashes on launch.
1. Clean install Fedora workstation rawhide 20170714, (XFS on thin LV)
2. Gnome-software > Installed > start removing applications, crash (bug 1469311)
3. Relaunch gnome-software, immediate crash (this bug)

Version-Release number of selected component:
gnome-software-3.25.3-5.fc27

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=3062775918374ba7bd351a2758c08637;i=1ed0;b=c12281a1a439467ba7ef5a82640cb8d3;m=748752f;t=554708b78c245;x=ced16e1ab2d5c0f1
kernel:         4.13.0-0.rc0.git6.1.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 1 Chris Murphy 2017-07-16 11:11:12 EDT
Created attachment 1299364 [details]
File: backtrace
Comment 2 Chris Murphy 2017-07-16 11:11:13 EDT
Created attachment 1299365 [details]
File: cgroup
Comment 3 Chris Murphy 2017-07-16 11:11:15 EDT
Created attachment 1299366 [details]
File: core_backtrace
Comment 4 Chris Murphy 2017-07-16 11:11:15 EDT
Created attachment 1299367 [details]
File: cpuinfo
Comment 5 Chris Murphy 2017-07-16 11:11:16 EDT
Created attachment 1299368 [details]
File: dso_list
Comment 6 Chris Murphy 2017-07-16 11:11:17 EDT
Created attachment 1299369 [details]
File: environ
Comment 7 Chris Murphy 2017-07-16 11:11:18 EDT
Created attachment 1299370 [details]
File: limits
Comment 8 Chris Murphy 2017-07-16 11:11:20 EDT
Created attachment 1299371 [details]
File: maps
Comment 9 Chris Murphy 2017-07-16 11:11:21 EDT
Created attachment 1299372 [details]
File: open_fds
Comment 10 Chris Murphy 2017-07-16 11:11:22 EDT
Created attachment 1299373 [details]
File: proc_pid_status
Comment 11 Chris Murphy 2017-07-16 11:11:23 EDT
Created attachment 1299374 [details]
File: var_log_messages
Comment 12 Chris Murphy 2017-07-16 11:23 EDT
Created attachment 1299375 [details]
journal.log

Tail end of the previous (removal) crash is at the top, 09:00:17 and earlier. The relaunch happens at 09:00:34.
Comment 13 Jan Kurik 2017-08-15 02:20:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 14 Maksim 2017-09-28 14:12:00 EDT
*** Bug 1496898 has been marked as a duplicate of this bug. ***
Comment 15 arturpolak1 2017-10-02 04:48:23 EDT
*** Bug 1497626 has been marked as a duplicate of this bug. ***
Comment 16 Peter 2017-10-02 13:53:12 EDT
*** Bug 1497810 has been marked as a duplicate of this bug. ***
Comment 17 Dawid Zamirski 2017-10-11 11:48:02 EDT
Similar problem has been detected:

Pressed the refresh button on the updates pane.

reporter:       libreport-2.9.2
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=90f7bb5473b147c0bf7998bbbf500f79;i=7443;b=7bc6c5978ce048e29968d9518f2a9bc7;m=119af51c58;t=55b4752e19f5a;x=756170808c9c2589
kernel:         4.13.5-300.fc27.x86_64
package:        gnome-software-3.26.1-1.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 18 msmafra 2017-10-27 08:15:30 EDT
*** Bug 1507016 has been marked as a duplicate of this bug. ***
Comment 19 Zdenek Chmelar 2017-11-05 17:45:26 EST
Similar problem has been detected:

I wanted to start the application. It crashed immediately it poped up.

reporter:       libreport-2.9.2
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=6c0aa1fea1da489581228d2094728002;i=12707e;b=5c486b35304b41788ceef10586bcaa3f;m=bf13c8600;t=55d4409f31e3f;x=6ed4931ee7bfc718
kernel:         4.13.9-300.fc27.x86_64
package:        gnome-software-3.26.1-3.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 20 Baptiste Mille-Mathias 2017-11-07 12:53:55 EST
Similar problem has been detected:

Click on the gnome-shell notification to see the update proposed and received the crash message immediatly

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=31fb789a73154adea32032ae1673d1dd;i=d9f0;b=514300af4eef4f869af9960a0ff13da7;m=c3b9cce;t=55d676c8be9fc;x=724719dc94bd530c
kernel:         4.13.11-300.fc27.x86_64
package:        gnome-software-3.26.1-3.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 21 Mike Basinger 2017-11-12 10:57:56 EST
Similar problem has been detected:

Happen at boot after upgrade to Fedora 27 beta.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=b73628d078f3467d84d6221c4aa5e4e2;i=c1dd6;b=c73921c48be64c1d8d22467302ca6fe1;m=8fa4544a;t=55dc2ab94eb76;x=90fbebffa7077923
kernel:         4.13.11-300.fc27.x86_64
package:        gnome-software-3.26.1-3.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 22 elias.wulcan 2017-11-17 02:29:11 EST
Similar problem has been detected:

I started Software and switched to updates tab, and the window immediately disappeared.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=91bc207ac4c346db8084d7a84923689d;i=29a24;b=ea491c9412ef4ec78191196c0eeb9cf7;m=c9759aeee;t=55e288462d8da;x=9ce372013249f8
kernel:         4.13.12-300.fc27.x86_64
package:        gnome-software-3.26.1-3.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Jeremy Harris 2017-11-17 09:59:15 EST
Similar problem has been detected:

application startup from desktop menu; immediate crash

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        gnome-software
crash_function: _pkgdb_item_free
executable:     /usr/bin/gnome-software
journald_cursor: s=47ec5e8ed28f486cb8746ec41cab051e;i=2569;b=65e0e35c69db4402903472c4e49d5cdb;m=1d46757eb;t=55e2ede422196;x=83a1a41ef7a53ed3
kernel:         4.13.11-300.fc27.x86_64
package:        gnome-software-3.26.1-3.fc27
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 24 Eugene.Dolgoff 2017-11-17 17:25:02 EST
*** Bug 1514619 has been marked as a duplicate of this bug. ***
Comment 25 Kalev Lember 2017-11-21 10:34:49 EST
This was fixed in gnome-software 3.26.2.
Comment 26 Alex NG 2017-11-22 00:04:34 EST
*** Bug 1516106 has been marked as a duplicate of this bug. ***
Comment 27 Vitalii 2017-11-22 09:40:07 EST
*** Bug 1516400 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.