This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471536 - RHEL-7 Installer should leave most space unallocated to allow XFS shrink.
RHEL-7 Installer should leave most space unallocated to allow XFS shrink.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-16 14:26 EDT by Charles Butterfield
Modified: 2017-08-18 12:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-18 12:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Butterfield 2017-07-16 14:26:54 EDT
Description of problem: Sadly the new default XFS filesystem is not shrinkable without LOTS of free space (for copy, nuke, recreate smaller, copy back).  However the default installer just scoops up all the free space and sticks in in an XFS filesystem.

So long as the default filesystem is XFS, the installer should not scoop up all the free space.  Frankly I think it should warn to poor user that XFS is non-shrinkable, many people will find that a problem.  Other than that the default installer is fine.  Perhaps an "XFS" vs "EXT4" filesystem option could be added, then taking the rest of the default stuff (which is otherwise great) would be feasible.


Version-Release number of selected component (if applicable):


How reproducible: totally


Steps to Reproduce:
1. Install taking all defaults
2. No spare space to shrink an XFS volume
3.

Actual results:


Expected results:


Additional info:
Comment 3 Samantha N. Bueno 2017-08-17 09:42:08 EDT
I don't think I 100% understand what's being asked for here.

If it's to change the default partitioning scheme to allow for a bunch of free space as a new standard, that's too much of a departure from default, expected behavior that has been present since RHEL-7.0. Changing partitioning defaults at this point would have too broad an impact and disrupt the user experience.

If it's to add some kind of warning dialog, I'm also not of a mind to do that. The limits of XFS are already addressed in our documentation[0] and in kbase articles[01] that have been written.

Therefore, setting dev_ack- on this.

[0] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Storage_Administration_Guide/xfsgrow.html

[01] https://access.redhat.com/solutions/540013
Comment 4 Red Hat Bugzilla Rules Engine 2017-08-17 09:42:15 EDT
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.
Comment 5 Charles Butterfield 2017-08-17 11:24:24 EDT
That argument has some merit, HOWEVER it overlooks the fact that the current behavior leaves the non-expert installer in a real bind (which certainly "affects the user experience").  Almost nobody reads up on all of the details of the default installation options - they are assumed to be reasonable and not contain hidden traps.

Sadly for the recent change to XFS as the default, combined with the other default of allocating all of the space, the non-expert user ends up in a real bind, namely they cannot re-adjust the partitions after installation.  This is such a significant departure (and trap) from previous RedHat user experience that something ought to be done.

What that "something" should should probably be the easiest thing to do (of the various possibilities).  Most likely a warning in the installer (perhaps just a comment somewhere in the partition selection dialogs) would make sense as opposed to a change in partitioning behavior.
Comment 6 Eric Sandeen 2017-08-17 11:31:11 EDT
It is possible today for the user to ask the installer to leave unpartitioned space - or to use ext4, if preferred.

I agree with Samantha that a change to the partitioning defaults midway through the RHEL7 lifecycle can't really be justified.  The user is already provided with options to avoid a fully-partitioned XFS root; they just need to be aware of the defaults and modify them during install if desired.
Comment 7 Samantha N. Bueno 2017-08-18 12:10:22 EDT
(In reply to Charles Butterfield from comment #5)
> That argument has some merit, HOWEVER it overlooks the fact that the current
> behavior leaves the non-expert installer in a real bind (which certainly
> "affects the user experience").  Almost nobody reads up on all of the
> details of the default installation options - they are assumed to be
> reasonable and not contain hidden traps. 

We do our best to mention important details such as FS limitations, etc., so that people are not caught off guard. Ultimately it is up to the user to make sure they read the documentation.

There are numerous workarounds here. I see from bug 1131589 that you are a customer with us. As was suggested there, I encourage you to open a support case with your representative. They can link your case to bug 1062667, which is the crux of the issue, and communicate any important developments to you about that. They can also work directly with you to find a good/better workaround tailored to your specific needs.

> 
> Sadly for the recent change to XFS as the default, combined with the other
> default of allocating all of the space, the non-expert user ends up in a
> real bind, namely they cannot re-adjust the partitions after installation. 
> This is such a significant departure (and trap) from previous RedHat user
> experience that something ought to be done.
> 
> What that "something" should should probably be the easiest thing to do (of
> the various possibilities).  Most likely a warning in the installer (perhaps
> just a comment somewhere in the partition selection dialogs) would make
> sense as opposed to a change in partitioning behavior.

Every file system has some limitations. We have to be mindful about what text we display to users since we don't want to clutter up the screen with too much information -- then users are less likely to read it. That is something we have actually received bug reports about in the past.

XFS has been the default FS in RHEL since 2014, and in Fedora since 2015. This is the first bug report I've seen filed against anaconda concerning space usage due to XFS's limitations. Therefore, the user experience concerning this does not seem unacceptable to most people, so I am very reluctant to change it.

I understand that this affects you, however, and I apologize for that. It's difficult to come up with a UX design that works for everybody. Again, I encourage you to work with your support representative to arrive at a solution.

Note You need to log in before you can comment on or make changes to this bug.