Bug 1471668 - "Aggregated logging is only supported using the journald driver in Docker" is wrong in documentations.
"Aggregated logging is only supported using the journald driver in Docker" is...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brandi
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 04:24 EDT by Junqi Zhao
Modified: 2018-05-02 15:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-02 15:34:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Junqi Zhao 2017-07-17 04:24:19 EDT
Logging not only support journald log driver, but also support json-file log driver now,  in the following documentations, there are description: 
"Aggregated logging is only supported using the journald driver in Docker", this is wrong.
I searched "Aggregated logging is only supported using the journald driver in Docker" at 
https://docs.openshift.com/container-platform/3.5/welcome/index.html
https://docs.openshift.org/latest/welcome/index.html

There are  6 pages is wrong, maybe not limited to these pages.

Document URL: 
https://docs.openshift.com/container-platform/3.5/install_config/aggregate_logging.html
https://docs.openshift.com/container-platform/3.5/install_config/install/host_preparation.html
https://docs.openshift.com/container-platform/3.5/install_config/revhistory_install_config.html
https://docs.openshift.com/container-platform/3.5/welcome/revhistory_full.html

https://docs.openshift.org/latest/install_config/install/host_preparation.html
https://docs.openshift.org/latest/install_config/aggregate_logging.html

Section Number and Name: 
Search "Aggregated logging is only supported using the journald driver in Docker" in the above pages.


Describe the issue: 
"Aggregated logging is only supported using the journald driver in Docker", Logging also supports json-file log driver.

Suggestions for improvement: 
Change "Aggregated logging is only supported using the journald driver in Docker" to
"Aggregated logging uses journald as default log driver in Docker".

Additional information:
Comment 1 Junqi Zhao 2017-07-17 04:26:16 EDT
@Jeff,

Do you have comments about "Suggestions for improvement" part, is that OK for the improvement?
Comment 2 Jeff Cantrill 2017-08-08 12:04:37 EDT
It is correct that we can support both drivers but we recommend using journald, the reasons that escape me now. We need to confirm if the statement should be something like:

* We recommend journal
* We support json as well.

Rich can you comment?
Comment 3 Rich Megginson 2017-08-08 12:16:58 EDT
We recommend journal because there is a lot more metadata available, but json-file is supported.
Comment 4 Peter Portante 2017-08-08 13:37:28 EDT
(In reply to Jeff Cantrill from comment #2)
> It is correct that we can support both drivers but we recommend using
> journald, the reasons that escape me now. We need to confirm if the
> statement should be something like:
> 
> * We recommend journal
> * We support json as well.

I think we have to support json-file until journald fully supports isolated quotas for amount of logs (curation) and rate of logging per-namespace.  Once it does, we'll want to drop json-file since there are performance implications with using it (file-system buffer pollution from all the writes, number of open file handles required to scale up per-node pod counts, and probably others).

Note You need to log in before you can comment on or make changes to this bug.