Bug 147182 - Update to initscripts-7.55.2-1 causes ifup failure on eth0
Update to initscripts-7.55.2-1 causes ifup failure on eth0
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2005-02-04 13:10 EST by Bill Warner
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-04 17:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
eth0 ifcfg file (183 bytes, text/plain)
2005-02-04 16:09 EST, Bill Warner
no flags Details
eth1 ifcfg file (144 bytes, text/plain)
2005-02-04 16:10 EST, Bill Warner
no flags Details
lo ifcfg file (254 bytes, text/plain)
2005-02-04 16:11 EST, Bill Warner
no flags Details

  None (edit)
Description Bill Warner 2005-02-04 13:10:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Update to initscripts-7.55.2-1 from initscripts-7.55.1-1 causes ifup
failure on eth0 at boot.

Downgrading back to initscripts-7.55.1-1 restores normal behavior.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum update initscripts (using released-updates repos.)
2. reboot

Actual Results:  From boot.log:

Feb  4 09:13:10 covenantpres ifup: Device eth0 has different MAC
address than expected, ignoring. 
Feb  4 09:13:10 covenantpres network: Bringing up interface eth0:  failed

Expected Results:  eth0 should come up as usual...

Additional info:

uname -a:
Linux covenantpres.org 2.6.10-1.12_FC2 #1 Wed Feb 2 01:13:49 EST 2005
i686 i686 i386 GNU/Linux
Comment 1 Bill Nottingham 2005-02-04 15:30:53 EST
Can you attach your ifcfg files?
Comment 2 Bill Warner 2005-02-04 16:09:17 EST
Created attachment 110670 [details]
eth0 ifcfg file
Comment 3 Bill Warner 2005-02-04 16:10:44 EST
Created attachment 110671 [details]
eth1 ifcfg file
Comment 4 Bill Warner 2005-02-04 16:11:46 EST
Created attachment 110672 [details]
lo ifcfg file
Comment 5 Bill Warner 2005-02-04 16:19:28 EST
ifcfg* files attached;
eth1 is not in use;
HWADDR in ifcfg-eth0 matches kernel probe:
eth0: Lite-On 82c168 PNIC rev 32 at d086a800, 00:02:E3:09:40:9B, IRQ 10.
Comment 6 Bill Warner 2005-02-04 16:25:30 EST
Aaargh, no it doesn't.  Byte order doesn't match.  Will edit
ifcfg-eth0 and try update again...
Comment 7 Bill Nottingham 2005-02-04 17:31:13 EST
Yes, this looks like a configuration error (mismatched hwaddr). Please
reopen if it persists after that is fixed.

Note You need to log in before you can comment on or make changes to this bug.