Bug 1471991 - NTFS partition will not mount read-write (it used to work)
NTFS partition will not mount read-write (it used to work)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 17:17 EDT by Alex
Modified: 2017-08-03 16:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-03 16:49:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex 2017-07-17 17:17:18 EDT
Description of problem: An NTFS partition on my laptop will no longer mount read-write, but it used to work ok a month or so ago (I don't know the ntfs-3g version that was working).


Version-Release number of selected component (if applicable): ntfs-3g 2017.3.23


How reproducible: Always


Steps to Reproduce:
1. Attempt to mount NTFS partition using Nautilus
2. Enter sudo/elevated password

Actual results:
NTFS partition is mounted read-only.

Expected results:
NTFS partition is mounted read-write.


Additional info: See two journal log snippets below from different dates, the same issue occurred on both dates. 

Please note in each case, ntfs-3g reports "rw" for "Cmdline options", but then reports both "rw" and "ro" for Mount options. I don't understand where these options are coming from, and why the mount options has both options, which doesn't make sense.

Jun 26 09:51:22 deneb udisksd[1930]: Mounted /dev/nvme0n1p8 at /run/media/alex/Data on behalf of uid 1000
Jun 26 09:51:22 deneb ntfs-3g[3957]: Version 2017.3.23 integrated FUSE 28
Jun 26 09:51:22 deneb ntfs-3g[3957]: Mounted /dev/nvme0n1p8 (Read-Only, label "Data", NTFS 3.1)
Jun 26 09:51:22 deneb ntfs-3g[3957]: Cmdline options: rw,nodev,nosuid,uid=1000,gid=1000,uhelper=udisks2
Jun 26 09:51:22 deneb ntfs-3g[3957]: Mount options: rw,nodev,nosuid,uhelper=udisks2,allow_other,nonempty,relatime,ro,default_permissions,fsname=/dev/nvme0n1p8,blkdev,blksize=4096
Jun 26 09:51:22 deneb ntfs-3g[3957]: Global ownership and permissions enforced, configuration type 7

Jul 17 22:00:32 deneb udisksd[1971]: Mounted /dev/nvme0n1p8 at /run/media/alex/Data on behalf of uid 1000
Jul 17 22:00:32 deneb ntfs-3g[3162]: Version 2017.3.23 integrated FUSE 28
Jul 17 22:00:32 deneb ntfs-3g[3162]: Mounted /dev/nvme0n1p8 (Read-Only, label "Data", NTFS 3.1)
Jul 17 22:00:32 deneb ntfs-3g[3162]: Cmdline options: rw,nodev,nosuid,uid=1000,gid=1000,uhelper=udisks2
Jul 17 22:00:32 deneb ntfs-3g[3162]: Mount options: rw,nodev,nosuid,uhelper=udisks2,allow_other,nonempty,relatime,ro,default_permissions,fsname=/dev/nvme0n1p8,blkdev,blksize=4096
Jul 17 22:00:32 deneb ntfs-3g[3162]: Global ownership and permissions enforced, configuration type 7
Comment 1 Jean-Pierre André 2017-07-18 03:14:51 EDT
Please plug the device, then unmount /run/media/alex/Data, then mount manually with no options to a user directory and post the output :

As root :
umount /run/media/alex/Data
mkdir /tmp/nvme
ntfs-3g /dev/nvme0n1p8 /tmp/nvme
Comment 2 Alex 2017-08-03 16:49:16 EDT
Hi there,

I followed the steps and this was the output:

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

As such I must apologise, this is not a bug.. my laptop is a dual-boot with Windows, and although I had previously disabled fast restarts in Windows in order to share the NTFS partition, it seems Windows decided to re-enable it by itself, possibly due to a recent update.. thanks Microsoft :)

Once I had disabled fast restarts (again), the partition is mounting read/write as expected :)

Apologies again, this is not a bug and I shall close it.

Note You need to log in before you can comment on or make changes to this bug.