Bug 147217 - gedit crashes when you try to open a file
gedit crashes when you try to open a file
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gedit (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 16:04 EST by Tim Skirvin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Skirvin 2005-02-04 16:04:16 EST
Description of problem:

The included gedit that comes with RH Desktop 3 crashes when you try
top open a file with it.  


Version-Release number of selected component (if applicable):

gedit-2.2.2-1

How reproducible:

Every time.

Steps to Reproduce:
1.  'touch filename.txt'
2.  'gedit filename.txt'
3.  "Could not open the file "/home/tskirvin/filename.txt" because it
contains invalid UTF-8 data.  Probably, you are trying to open a
binary file."  Error messages with it: (gedit:18650): GLib-CRITICAL
**: file gutf8.c: line 1536 (g_utf8_validate): assertion `str != NULL'
failed

(gedit:18650): GLib-CRITICAL **: file gutf8.c: line 1536
(g_utf8_validate): assertion `str != NULL' failed

(gedit:18650): GLib-CRITICAL **: file gutf8.c: line 1536
(g_utf8_validate): assertion `str != NULL' failed

(gedit:18650): GLib-CRITICAL **: file gutf8.c: line 1536
(g_utf8_validate): assertion `str != NULL' failed

** (gedit:18650): CRITICAL **: file gedit-utils.c: line 1607
(gedit_utils_convert_to_utf8_from_charset): assertion `content !=
NULL' failed

** (gedit:18650): CRITICAL **: file gedit-utils.c: line 1607
(gedit_utils_convert_to_utf8_from_charset): assertion `content !=
NULL' failed

** (gedit:18650): CRITICAL **: file gedit-utils.c: line 1607
(gedit_utils_convert_to_utf8_from_charset): assertion `content !=
NULL' failed

** (gedit:18650): CRITICAL **: file gedit-utils.c: line 1607
(gedit_utils_convert_to_utf8_from_charset): assertion `content !=
NULL' failed

4.  'echo "hi there" >> filename.txt

5.  'gedit filaname.txt' 
Application "gedit" (process 18719) has crashed
due to a fatal error.
(Aborted)

GLib-ERROR **: gmem.c:140: failed to allocate 206158430218 bytes
aborting...



  
Actual results:

Crashes and/or claims that it's a binary file.


Expected results:

Would like to edit the actual file.


Additional info:
Comment 2 Girish C 2005-04-08 04:50:10 EDT
One of the fix to this problem is:
initialize file_size  = 0 inside gedit_document_load()function at line no. 662 
of gedit-document.c which calls eel_read_entire_file (uri, &file_size, 
&file_contents); and return proper value for empty files and non empty files.

Regards
Girish
Comment 3 RHEL Product and Program Management 2007-10-19 15:07:40 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.