Bug 147218 - RHEL3: System freezes shortly after activating 3c590 NIC card
RHEL3: System freezes shortly after activating 3c590 NIC card
Status: CLOSED DUPLICATE of bug 147039
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: dff
Kernel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 16:07 EST by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 19:38:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2005-02-04 16:07:57 EST
*** This bug has been split off bug 147039 ***

------- Original comment by Thomas Payerle on 2005.02.03 16:38 -------

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
I have a Dell Optiplex GX1p had been running RHL7.x for years and
upgraded to REL AS 3 from update 1 CDs.  Only hardware change during
upgrade was to make old drive a slave and add new master HDD.

System has eth0 as 3c905B, and eth1 as 3c590
The former is on a public internet, the latter on a small private net.
Not set up to do routing or anything fancy.

Both were detected and configured during installation from CD, and
install process proceeded normally to first reboot.  After reboot,
graphical 1st boot up screen comes up, and system froze before I could
finish reading the license (a few minutes after X came up).  Screen
does not change, but no response from mouse or keyboard (numlock LED
would work, that is it.  CAp lock did not).  Eventually was able to
boot to old RH7x setup, and it behaved normally for several hours.
I could not even ping the machine after it froze.

Booting to single-user mode, the system seems to stay up indefinitely
(15+ minutes, 3-5 times longer than onset of problems when occur).
I manually ran S* scripts from /etc/rc5.d, and system froze several
minutes after done.  By selectively running scripts, narrowed down
to S10network script as culprit (running S0* system stays up, run
S10network after others system locks up).

I renamed /etc/sysconfig/network-scripts/ifcfg-eth1, and system would
come up in full X11 multiuser mode, and stay up indefinitely (had up
w/out probs on order 12 hours or more).  If I run ifconfig to config
the 3c590 NIC, system will freeze up several minutes later.

Updated with up2date will all available patches, so should be a 
current Update4/Taroon now, and problem persists.

Rebooting to single user mode, I try running S0* in /etc/rc5.d, then
ifup eth1 (after restoring original ifcfg-eth1).  So eth0 was not
configured.  System still locked up after a couple of minutes.




Version-Release number of selected component (if applicable):
kernel-2.4.21-9.EL

How reproducible:
Always

Steps to Reproduce:
1.boot without eth1 activated
2.ifconfig eth1 172.17.172.17 netmask 255.255.0.0 broadcast 172.17.255.255
3.system will freeze after a couple of minutes
    

Actual Results:  machine would not respond to keyboard, mouse, or
pings.  Screen
stayed normal

Expected Results:  system should still run

Additional info:

Additional details to be supplied as attachments
Comment 3 Ernie Petrides 2005-10-06 19:38:53 EDT
Converting back to BZ and closing as dup of source BZ.

*** This bug has been marked as a duplicate of 147039 ***

Note You need to log in before you can comment on or make changes to this bug.