Bug 147222 - grubby horks new entry when console=tty0 console=ttyS1,9600n81
grubby horks new entry when console=tty0 console=ttyS1,9600n81
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
: 167055 (view as bug list)
Depends On:
Blocks: 156320 156322
  Show dependency treegraph
 
Reported: 2005-02-04 16:24 EST by Brian Long
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-724
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf before running grubby (834 bytes, text/plain)
2005-02-04 16:25 EST, Brian Long
no flags Details
grub.conf after grubby (1.03 KB, text/plain)
2005-02-04 16:26 EST, Brian Long
no flags Details

  None (edit)
Description Brian Long 2005-02-04 16:24:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
I have two existing grub.conf entries, UP and SMP kernels.  Each
kernel has similar options including "console=tty0
console=ttyS1,9600n81".  When I call grubby to add another kernel
using --copy-default, the new kernel entry has options
"console=ttyS1,9600n81 console=ttyS1,9600n81".  

Version-Release number of selected component (if applicable):
mkinitrd-3.5.13-1

How reproducible:
Always

Steps to Reproduce:
1. Populate grub.conf with kernel option 'console=tty0
console=ttyS1,9600n81'
2. Run grubby '--title=Cisco-Enterprise-Linux (2.4.21-27.0.1.EL)
SINGLEUSER' --copy-default
--add-kernel=/boot/vmlinuz-2.4.21-27.0.1.ELsingle '--args=ro
root=LABEL=/ console=tty0 console=ttyS1,9600n81 single' '--initrd=   
 /initrd-2.4.21-27.0.1.EL.img'


Actual Results:  New grub.conf entry has 'console=ttyS1,9600n81
console=ttyS1,9600n81'.

Expected Results:  New grub.conf should have 'console=tty0
console=ttyS1,9600n81 single'

Additional info:
Comment 1 Brian Long 2005-02-04 16:25:49 EST
Created attachment 110674 [details]
grub.conf before running grubby
Comment 2 Brian Long 2005-02-04 16:26:24 EST
Created attachment 110675 [details]
grub.conf after grubby

Contains two kernel options console=ttyS1,9600n81.
Comment 13 Peter Jones 2005-08-29 17:05:03 EDT
*** Bug 167055 has been marked as a duplicate of this bug. ***
Comment 15 Red Hat Bugzilla 2005-09-28 15:09:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-693.html
Comment 16 Red Hat Bugzilla 2005-10-05 13:28:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-724.html

Note You need to log in before you can comment on or make changes to this bug.