Bug 147225 - kernel 2.6.10-1.760_FC3 paging error
kernel 2.6.10-1.760_FC3 paging error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 16:52 EST by Eric Yeo
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-04 03:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Yeo 2005-02-04 16:52:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
This was observed in the logs overnight while running amanda:

Feb  5 02:05:27 bombadil kernel: Unable to handle kernel paging
request at virtu
al address ad12331b
Feb  5 02:05:27 bombadil kernel:  printing eip:
Feb  5 02:05:27 bombadil kernel: ad12331b
Feb  5 02:05:27 bombadil kernel: *pde = 00000000
Feb  5 02:05:27 bombadil kernel: Oops: 0000 [#1]
Feb  5 02:05:27 bombadil kernel: Modules linked in: vmnet(U) vmmon(U)
nfsd expor
tfs parport_pc lp parport i2c_dev i2c_core nfs lockd sunrpc ipt_REJECT
ipt_state
 ip_conntrack iptable_filter ip_tables microcode md5 ipv6 dm_mod
joydev uhci_hcd
 snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd sou
ndcore snd_page_alloc 8139too mii floppy st ext3 jbd aic7xxx sd_mod
scsi_mod
Feb  5 02:05:27 bombadil kernel: CPU:    0
Feb  5 02:05:27 bombadil kernel: EIP:    0060:[<ad12331b>]    Tainted:
P      VL
I
Feb  5 02:05:27 bombadil kernel: EFLAGS: 00010246   (2.6.10-1.760_FC3) 
Feb  5 02:05:27 bombadil kernel: EIP is at 0xad12331b
Feb  5 02:05:27 bombadil kernel: eax: c03d5fa0   ebx: ee4f6c80   ecx:
d2c99000  
 edx: 00000000
Feb  5 02:05:27 bombadil kernel: esi: dffef6f0   edi: c03d5fa0   ebp:
c02fd623  
 esp: c2fd4ecc
Feb  5 02:05:27 bombadil kernel: ds: 007b   es: 007b   ss: 0068
Feb  5 02:05:27 bombadil kernel: Process taper (pid: 6570,
threadinfo=c2fd4000 t
ask=dffef6f0)
Feb  5 02:05:27 bombadil kernel: Stack: 00000c5e dffeec10 00007552
ad12331b 0000
0c5e dffef180 dffef87c c2fd4f1c 
Feb  5 02:05:27 bombadil kernel:        f723fc18 c2fd4f10 c2fd4fac
c016e083 0000
0000 dffef6f0 c01332f0 c2fd4f28 
Feb  5 02:05:27 bombadil kernel:        c2fd4f28 e1cba218 e527fac0
c2fd4f3c 0000
0000 dffef6f0 c01332f0 c2fd4f28 
Feb  5 02:05:27 bombadil kernel: Call Trace:
Feb  5 02:05:27 bombadil kernel:  [<c016e083>] pipe_wait+0x67/0x96
Feb  5 02:05:27 bombadil kernel:  [<c01332f0>]
autoremove_wake_function+0x0/0x2d
Feb  5 02:05:27 bombadil kernel:  [<c01332f0>]
autoremove_wake_function+0x0/0x2d
Feb  5 02:05:27 bombadil kernel:  [<c016e283>] pipe_readv+0x1d1/0x249
Feb  5 02:05:27 bombadil kernel:  [<c016e317>] pipe_read+0x1c/0x20
Feb  5 02:05:27 bombadil kernel:  [<c0160c1f>] vfs_read+0xb6/0xe2
Feb  5 02:05:27 bombadil kernel:  [<c0160e32>] sys_read+0x3c/0x62
Feb  5 02:05:27 bombadil kernel:  [<c0103443>] syscall_call+0x7/0xb
Feb  5 02:05:27 bombadil kernel: Code:  Bad EIP value.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.760_FC3

How reproducible:
Sometimes

Steps to Reproduce:
Amanda almost always hangs the machine in the pass with older kernel.
But this particular kernel, we have observed the message in the logs.
This kernel has also hang on me twice with any warning or log messages.

Actual Results:  The log message was observed.

Expected Results:  Should not have received log message.

Additional info:
Comment 1 Dave Jones 2005-02-04 16:58:57 EST
can you reproduce this without the vmware modules loaded ?
Comment 2 Eric Yeo 2005-02-05 01:09:12 EST
I think I have identified the cause of the instability. I tunred off
32-bit IO for the IDE harddisks and I was able to perform backup
without problems. This was with the vmware modules loaded. Problems
with 32-bit IO in the IDE driver perhaps?
Comment 3 Eric Yeo 2005-02-05 17:06:23 EST
It appears that I have spoke too soon. Overnight the system hang
during the backup. This time there wasn't any messages in the logs. I
will try to disable vmware for the backup tonight.
Comment 4 Eric Yeo 2005-02-09 02:28:37 EST
I managed to get a successful overnight backup with my USB hub and
Palm T3 disconnected. When I have the Palm connected last night, the
system hang after backup. I will have the Palm disconnected again
tonight to confirm the cause. Will also try placing the visor module
in the blacklist and see if it is the cause the system hang. I
wouldn't have thought that the palm would be a problem when it is idle.
Comment 5 Dave Jones 2005-02-09 20:58:21 EST
I'm strongly suspicious of those vmware modules. If you manage to reproduce this
without them, please reopen.
Comment 6 Eric Yeo 2005-02-09 21:23:38 EST
I have reproduced this without the VMware modules. This was reproduced without 
VMWare modules but with my USB Hub and Palm plugged in.
Comment 7 Eric Yeo 2005-02-11 15:45:21 EST
After a few days of trying to isolate the cause, I have gotten to system to be
stable. This is a summary of the things I did:

1. Turn off 32-bit I/O appears to make the systm more stable but it still hangs,
2. Removed the package sysstat (which I noticed was the only thing running at
those times when the system hung mysteriously),
3. Changed the BIOS setting to allow PnP for all devices/interrupts (previously
there was 1 device and 1 interrupt marked as not supporting PnP).

My machine has been running continuously for more than 2 days doing overnight
backups now with VMWare modules active and my Palm plugged in. I have my problem
solved but you may wish to pursue this further or close the issue.

Note You need to log in before you can comment on or make changes to this bug.