Bug 1472251 - project admin should be able to create / get / delete podpreset
project admin should be able to create / get / delete podpreset
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.7.0
Assigned To: Paul Morie
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 06:06 EDT by Weihua Meng
Modified: 2017-10-17 16:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-17 15:37:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Weihua Meng 2017-07-18 06:06:47 EDT
Description of problem:
project admin cannot create / get / delete podpreset

Version-Release number of selected component (if applicable):
openshift v3.6.152.0

How reproducible:
Always

Steps to Reproduce:
1. # oc create -f podpreset.yaml 
2.
3.

Actual results:
Error from server (Forbidden): error when creating "podpreset.yaml": User "wmeng" cannot create podpresets.settings.k8s.io in project "wmeng"


Expected results:
podpreset "allow-database" created

Additional info:
related: https://bugzilla.redhat.com/show_bug.cgi?id=1471013
Comment 1 Jordan Liggitt 2017-07-18 10:22:09 EDT
isn't this something the installer should be setting up in this release?
Comment 2 Jordan Liggitt 2017-07-18 10:22:48 EDT
and actually, https://github.com/openshift/openshift-ansible/pull/4765/files#diff-d66acb2fb119175c74e61c714e6bf52eR15 should have resolved it
Comment 3 DeShuai Ma 2017-07-18 12:44:06 EDT
(In reply to Jordan Liggitt from comment #2)
> and actually,
> https://github.com/openshift/openshift-ansible/pull/4765/files#diff-
> d66acb2fb119175c74e61c714e6bf52eR15 should have resolved it

This can take effect only when enable service-catalog, but sometime we only need podpreset. Though service-catalog use podpreset, but they should separate.
Comment 4 Paul Morie 2017-07-18 14:07:46 EDT
We actually do not want to enable pod preset unless the catalog is enabled at this time.
Comment 5 Paul Morie 2017-07-18 14:12:01 EDT
I'm moving this to 3.7.0 because it's arguable that this should be done at that time.  In 3.6 you should only get PodPreset if you install the catalog.
Comment 6 Paul Morie 2017-10-17 15:28:09 EDT
We're actually going to be removing PodPreset entirely in openshift 3.7, so this is NOTABUG

Note You need to log in before you can comment on or make changes to this bug.