Bug 1472389 - default LVM volume group has different name when using ISO vs cloud image
default LVM volume group has different name when using ISO vs cloud image
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-18 11:34 EDT by Micah Abbott
Modified: 2017-07-19 09:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 09:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micah Abbott 2017-07-18 11:34:35 EDT
After booting a 7.4 cloud image:

# vgdisplay | grep 'VG Name'
  VG Name               atomicos


After installing via ISO:

# vgdisplay | grep 'VG Name'
  VG Name               rhelah



Turns out this has been around for a while.  Found the same discrepancy when comparing a 7.3.x ISO and 7.3.x cloud image
Comment 1 Jonathan Lebon 2017-07-18 12:33:05 EDT
Yeah, I suppose we should try to be consistent. :) Between the two, I'd vote for atomicos, since that's what's used upstream as well.
Comment 3 Jonathan Lebon 2017-07-18 17:32:15 EDT
This took some digging around, though it seems like blivet takes "rhelah" from anaconda, which comes up with it by just taking the first letter of each word in the product name (in our case, the product name being "Red Hat Enterprise Linux Atomic Host").

Changing this would require mucking around with one or more of rpm-ostree-toolbox, anaconda, or blivet. I'm not sure how much it's worth it given the issue, so I'm inclined to change my opinion and instead change the cloud image to also be "rhelah". Does that work?

AFAIU, this is just for cosmetics, right? (And I suppose, to make KBs & docs more easily apply to both cases?) Or is this discrepancy causing some other subtle issues?
Comment 5 Micah Abbott 2017-07-19 08:55:22 EDT
> AFAIU, this is just for cosmetics, right? (And I suppose, to make KBs & docs
> more easily apply to both cases?) Or is this discrepancy causing some other
> subtle issues?

Correct, cosmetics and consistency in docs.
Comment 6 Jonathan Lebon 2017-07-19 09:46:25 EDT
Closing as NOTABUG. Docs for cloud images which use "atomicos" are too prevalent already. Changing the default on the installer ISO side is not worth it, given that admins could just as well rename it at install time.

Note You need to log in before you can comment on or make changes to this bug.