Bug 147248 - gcc reports: ./rehearsetimingsactivity.hxx:193: internal compiler error: in resolve_overloaded_unification, at cp/pt.c:9309
gcc reports: ./rehearsetimingsactivity.hxx:193: internal compiler error: in r...
Status: CLOSED DUPLICATE of bug 144369
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-04 19:06 EST by Steve Murphy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 13:52:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source stored into this file and attached as directed. (227.84 KB, text/plain)
2005-02-04 19:23 EST, Steve Murphy
no flags Details

  None (edit)
Description Steve Murphy 2005-02-04 19:06:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Making: ../../unxlngi4.pro/slo/presentation.obj
g++ -Wuninitialized -fmessage-length=0 -c -I.  -I. -I../inc
-I../../inc -I../../unx/inc -I../../unxlngi4.pro/inc -I.
-I/usr/local/src/OOo_1.9.m74_src/solver/680/unxlngi4.pro/inc/stl
-I/usr/local/src/OOo_1.9.m74_src/solver/680/unxlngi4.pro/inc/external
-I/usr/local/src/OOo_1.9.m74_src/solver/680/unxlngi4.pro/inc
-I/usr/local/src/OOo_1.9.m74_src/solenv/unxlngi4/inc
-I/usr/local/src/OOo_1.9.m74_src/solenv/inc
-I/usr/local/src/OOo_1.9.m74_src/res
-I/usr/local/src/OOo_1.9.m74_src/solver/680/unxlngi4.pro/inc/stl
-I/usr/local/src/OOo_1.9.m74_src/solenv/inc/Xp31
-I/usr/java/j2sdk1.4.2_07/include
-I/usr/java/j2sdk1.4.2_07/include/linux
-I/usr/java/j2sdk1.4.2_07/include/native_threads/include
-I/usr/X11R6/include     -I. -I../../res -I. -O1   -pipe
-mcpu=pentiumpro -Wno-ctor-dtor-privacy -include preinclude.h
-fexceptions -fno-enforce-eh-specs   -fpic -DLINUX -DUNX -DVCL -DGCC
-DC300 -DINTEL
-DGXX_INCLUDE_PATH=/usr/lib/gcc/i386-redhat-linux/3.4.2/../../../../include/c++/3.4.2
-DCVER=C300 -D_USE_NAMESPACE -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT
-DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -D__DMAKE -DUNIX
-DCPPU_ENV=gcc3 -DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL
-DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA
-DSRC680   -DSHAREDLIB -D_DLL_  -DMULTITHREAD  -o
../../unxlngi4.pro/slo/presentation.o
/usr/local/src/OOo_1.9.m74_src/slideshow/source/engine/presentation.cxx
In file included from
/usr/local/src/OOo_1.9.m74_src/slideshow/source/engine/presentation.cxx:175:
./rehearsetimingsactivity.hxx: In member function `FuncT
presentation::internal::RehearseTimingsActivity::for_each_sprite(FuncT)
const':
./rehearsetimingsactivity.hxx:193: internal compiler error: in
resolve_overloaded_unification, at cp/pt.c:9309
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccaODx4U.out file, please attach
this to your bugreport.


Version-Release number of selected component (if applicable):
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

How reproducible:
Always

Steps to Reproduce:
1. Building OpenOffice OOo_1.9.m74_src on FC3.
2. did the dmake; a large amount of processing precedes the error.
3.
    

Expected Results:  The more or less silent compilation of the c++ file.


Additional info:
Comment 1 Steve Murphy 2005-02-04 19:23:01 EST
Created attachment 110684 [details]
Preprocessed source stored into this file and attached as directed.

Preprocessed source stored into /tmp/ccaODx4U.out file, please attach this to
your bugreport.

Yes, master!
Comment 2 Jakub Jelinek 2005-02-08 13:52:08 EST

*** This bug has been marked as a duplicate of 144369 ***

Note You need to log in before you can comment on or make changes to this bug.