Bug 147255 - Cannot mount removable devices as a user
Cannot mount removable devices as a user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 04:09 EST by Sarantis Paskalis
Modified: 2013-07-02 19:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-05 12:34:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sarantis Paskalis 2005-02-05 04:09:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I cannot mount removable devices in FC3.  It started with
usermode-1.74-1. After searching through bugzilla, there were two bugs
(bug #146618 and bug #139820) that claimed that usermode update to
1.76-1 would solve the problem.

Problem persists with usermode-1.78-1 (grabbed from rawhide).
Relevant fstab lines:

/dev/sda1               /media/usbdisk          vfat   
pamconsole,exec,noauto,iocharset=utf8,noatime,sync,fscontext=system_u:object_r:removable_t,managed
0 0
/dev/hdd                /media/cdrecorder       auto   
pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0
/dev/hdc                /media/cdrom            auto   
pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0
/dev/fd0                /media/floppy           auto   
pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

System fully updated.

Version-Release number of selected component (if applicable):
usermode-1.78-1

How reproducible:
Always

Steps to Reproduce:
1. Insert a cdrom, usbstick, etc
2. cdrom is not mounted as a user
3.
    

Additional info:
Comment 1 Sarantis Paskalis 2005-03-05 12:34:08 EST
I found out what was causing this.  This is a box constantly updated from
previous releases.  util-linux was stuck at util-linux-2.12pre-3, while the
version shipped with FC3 was util-linux-2.12a-16.  rpm did not update it, so it
could not identify the pamconsole keyword.

I installed util-linux-2.12a-16, and everything seems to work ok now.  Closing
the bug.
Comment 2 Jindrich Novy 2005-03-07 02:28:20 EST
Sarantis, thanks for the explanation and closing the bug.

Jindrich

Note You need to log in before you can comment on or make changes to this bug.