Bug 147258 - agp_backend_initialize() failed with Xen on IBM Thinkpad T21
agp_backend_initialize() failed with Xen on IBM Thinkpad T21
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 09:18 EST by Alexander Boström
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 01:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Boström 2005-02-05 09:18:14 EST
Description of problem:

Using kernel 2.6.10-1.1124_FC4xen0 on an IBM Thinkpad T21 (S3
Savage/IX-MV graphics), agpgart won't initialize. (Distribution is FC3.)

dmesg:

Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 440BX Chipset.
agpgart: Maximum main memory to use for agp memory: 93M
agpgart: unable to get memory for graphics translation table.
agpgart: agp_backend_initialize() failed.
agpgart-intel: probe of 0000:00:00.0 failed with error -12

Last known working Xen kernel was 2.6.9-1.1020_FC4xen0 (but see bug
#142046). I haven't tried any later Xen kernel except
2.6.10-1.1124_FC4xen0.

Same kernel without xen0 also works.

Version-Release number of selected component (if applicable):
2.6.10-1.1124_FC4xen0

How reproducible:
Always.
Comment 1 Alexander Boström 2005-02-05 09:25:31 EST
See also bug #143078.
Comment 2 Alexander Boström 2005-03-13 14:16:54 EST
Using 2.6.11-1.1177_FC4xen0, agpgart does initialise without any error, but the
PCI-AGP bridge and the VGA compatible controller are missing anyway (in lspci)
for some reason.

Note that this is FC3 + xen package and kernel from FCdev. I chose to --nodeps
install xen because of a python 2.4 dependency. I'm tempted to try FCdev instead
although I doubt it'll matter in this case.
Comment 3 Dave Jones 2005-10-06 01:00:51 EDT
iirc, this got fixed in subsequent kernels.

Note You need to log in before you can comment on or make changes to this bug.