Bug 1472606 - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 02:02 EDT by Mikhail
Modified: 2017-10-03 09:01 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 08:01:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2017-07-19 02:02:54 EDT
Description of problem:

# dnf upgrade
Last metadata expiration check: 0:32:06 ago on Wed 19 Jul 2017 10:27:28 AM +05.
Dependencies resolved.

 Problem 1: cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package xen-libs-4.8.1-5.fc27.x86_64
  - cannot install the best update candidate for package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64
 Problem 2: package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package qemu-system-x86-2:2.9.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-3.5.0-1.fc27.x86_64
 Problem 3: problem with installed package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-libs-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libvirt-libs-3.5.0-1.fc27.x86_64
 Problem 4: package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-config-network-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package qemu-kvm-2:2.9.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-config-network-3.5.0-1.fc27.x86_64
 Problem 5: problem with installed package qemu-system-x86-2:2.9.0-1.fc27.x86_64
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-driver-interface-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package libvirt-daemon-driver-interface-3.5.0-1.fc27.x86_64
 Problem 6: package libvirt-daemon-kvm-3.5.0-2.fc27.x86_64 requires qemu-kvm, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-driver-network-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package libvirt-daemon-kvm-3.5.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-driver-network-3.5.0-1.fc27.x86_64
 Problem 7: package libvirt-daemon-kvm-3.5.0-2.fc27.x86_64 requires qemu-kvm, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package gnome-boxes-3.25.3-1.fc27.x86_64 requires libvirt-daemon-kvm, but none of the providers can be installed
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-kvm-3.5.0-1.fc27.x86_64 requires libvirt-daemon-driver-nodedev = 3.5.0-1.fc27, but none of the providers can be installed
  - package libvirt-daemon-driver-nodedev-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install both libvirt-daemon-driver-nodedev-3.5.0-2.fc27.x86_64 and libvirt-daemon-driver-nodedev-3.5.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-driver-nodedev-3.5.0-1.fc27.x86_64
  - cannot install the best update candidate for package gnome-boxes-3.25.3-1.fc27.x86_64
 Problem 8: package libvirt-daemon-kvm-3.5.0-2.fc27.x86_64 requires qemu-kvm, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - problem with installed package libvirt-daemon-kvm-3.5.0-1.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-kvm-3.5.0-1.fc27.x86_64 requires libvirt-daemon-driver-nwfilter = 3.5.0-1.fc27, but none of the providers can be installed
  - package libvirt-daemon-driver-nwfilter-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install both libvirt-daemon-driver-nwfilter-3.5.0-2.fc27.x86_64 and libvirt-daemon-driver-nwfilter-3.5.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-driver-nwfilter-3.5.0-1.fc27.x86_64
 Problem 9: problem with installed package qemu-kvm-2:2.9.0-1.fc27.x86_64
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-driver-qemu-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install the best update candidate for package libvirt-daemon-driver-qemu-3.5.0-1.fc27.x86_64
 Problem 10: problem with installed package gnome-boxes-3.25.3-1.fc27.x86_64
  - package gnome-boxes-3.25.3-1.fc27.x86_64 requires libvirt-daemon-kvm, but none of the providers can be installed
  - package libvirt-daemon-kvm-3.5.0-2.fc27.x86_64 requires qemu-kvm, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.9.0-1.fc27.x86_64 and xen-libs-4.8.1-5.fc27.x86_64
  - package libvirt-daemon-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - package libvirt-daemon-kvm-3.5.0-1.fc27.x86_64 requires libvirt-daemon-driver-secret = 3.5.0-1.fc27, but none of the providers can be installed
  - package libvirt-daemon-driver-secret-3.5.0-2.fc27.x86_64 requires libvirt-daemon = 3.5.0-2.fc27, but none of the providers can be installed
  - cannot install both libvirt-daemon-driver-secret-3.5.0-2.fc27.x86_64 and libvirt-daemon-driver-secret-3.5.0-1.fc27.x86_64
  - cannot install the best update candidate for package libvirt-daemon-driver-secret-3.5.0-1.fc27.x86_64
===============================================================================
 Package                           Arch     Version            Repository
                                                                          Size
===============================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 libvirt-daemon-driver-nodedev     x86_64   3.5.0-2.fc27       rawhide    61 k
 libvirt-daemon-driver-nwfilter    x86_64   3.5.0-2.fc27       rawhide    84 k
 libvirt-daemon-driver-secret      x86_64   3.5.0-2.fc27       rawhide    49 k
 xen-libs                          x86_64   4.9.0-1.fc27       rawhide   670 k
Skipping packages with broken dependencies:
 gnome-boxes                       x86_64   3.25.3-1.fc27      rawhide   1.0 M
 libvirt-daemon                    x86_64   3.5.0-2.fc27       rawhide   729 k
 libvirt-daemon-config-network     x86_64   3.5.0-2.fc27       rawhide    13 k
 libvirt-daemon-driver-interface   x86_64   3.5.0-2.fc27       rawhide    60 k
 libvirt-daemon-driver-network     x86_64   3.5.0-2.fc27       rawhide   231 k
 libvirt-daemon-driver-qemu        x86_64   3.5.0-2.fc27       rawhide   560 k
 libvirt-daemon-kvm                x86_64   3.5.0-2.fc27       rawhide    11 k
 libvirt-libs                      x86_64   3.5.0-2.fc27       rawhide   4.1 M
 qemu-kvm                          x86_64   2:2.9.0-1.fc27     rawhide    20 k
 qemu-system-x86                   x86_64   2:2.9.0-1.fc27     rawhide    20 k
 qemu-system-x86-core              x86_64   2:2.9.0-1.fc27     rawhide   5.3 M

Transaction Summary
===============================================================================
Skip  15 Packages

Nothing to do.
Complete!
Comment 1 Cole Robinson 2017-07-19 08:01:19 EDT
Should be fixed in libvirt-3.5.0-2.fc27

Note You need to log in before you can comment on or make changes to this bug.