Bug 147267 - Inventor SRPM fails on AMD64
Inventor SRPM fails on AMD64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Inventor (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Corsepius
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 15:40 EST by Andy Loening
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 13:55:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A new spec file for the Inventor package (9.12 KB, text/plain)
2005-02-05 15:42 EST, Andy Loening
no flags Details
spec diff (2.58 KB, patch)
2005-02-07 06:50 EST, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Andy Loening 2005-02-05 15:40:42 EST
The Inventor SRPM fails to build on the AMD64 architecture.  A
modified .spec file is included to get Inventor to build correctly.
Comment 1 Andy Loening 2005-02-05 15:42:01 EST
Created attachment 110694 [details]
A new spec file for the Inventor package
Comment 2 Thorsten Leemhuis 2005-02-07 05:39:44 EST
Ralf, I can confirm that Inventor builds on x86_64 with the spec in attachment
(id=110694).

Andy, just FYI: Next time please attach a diff for the spec file and not the
whole new spec file -- then it's way easier to see what you changed. And also
add a changelog entry next time.
Comment 3 Ralf Corsepius 2005-02-07 06:00:13 EST
(In reply to comment #2)
> Ralf, I can confirm that Inventor builds on x86_64 with the spec in attachment
> (id=110694) [edit].
Well, you know, I suspect multilibs in Rh's x86_64 to be broken, so all this
*.spec changes probably means playing with symptoms. 

Unfortunately, I don't have access to x86_64 systems, so identifying and
verifying such bugs is hardly possible for me. I think I am going to ask on
fedora-devel@ and may-be on gcc@.

> Andy, just FYI: Next time please attach a diff for the spec file and not the
> whole new spec file -- then it's way easier to see what you changed. And also
> add a changelog entry next time.
Exactly, this would have helped tremendously. Now, I'll have to find a timeslot
and have to check the diff myself :-(
Comment 4 Michael Schwendt 2005-02-07 06:27:22 EST
Theoretically, the fix is correct. %_libdir expands to /usr/lib64 on x86_64 and
%_lib to lib64. So far, I'm not much of a fan of publishing untested x86_64
builds, but since all packages were rebuilt, we seem to use that as a Rawhide
kind of start for that platform. 99% of the released x86_64 Fedora Extras
packages are untested mass-rebuilds and would benefit from x86_64 specific
maintainers. In case Inventor fails horribly, e.g. in the demos/examples, it
better be ExcludeArch x86_64.
Comment 5 Ralf Corsepius 2005-02-07 06:38:37 EST
(In reply to comment #4)
> Theoretically, the fix is correct. %_libdir expands to /usr/lib64 on x86_64
> and %_lib to lib64

Theoretically gcc -m64 -L/usr/X11R6/lib should expand to
gcc -m64 -L/usr/X11R6/lib/../lib64

This is how multilibs work on all platforms but x86_64-redhat.
Comment 6 Michael Schwendt 2005-02-07 06:50:33 EST
Created attachment 110714 [details]
spec diff

I referred to the spec diff only.
Comment 7 Thorsten Leemhuis 2005-02-10 10:14:32 EST
Ralf, what do you think on the spec-file-patch -- is it okay with you
if we push it?
Comment 8 Thorsten Leemhuis 2005-02-16 13:48:35 EST
Commited to CVS, will request build later. Ralf, Andy, can you close this bug?
Thanks.

Note You need to log in before you can comment on or make changes to this bug.