Bug 147268 - GtkDeprecationWarning: in hwbrowser
GtkDeprecationWarning: in hwbrowser
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hwbrowser (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 16:06 EST by Jason
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-12 14:50:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-02-05 16:06:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I ran hwbrowser and I get these messages

/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainiteration is deprecated, use
gtk.main_iteration instead
  self.warn(message, DeprecationWarning)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
  self.warn(message, DeprecationWarning)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainquit is deprecated, use gtk.main_quit
instead
  self.warn(message, DeprecationWarning)


Version-Release number of selected component (if applicable):
hwbrowser-0.19-0.fc3.2.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. look at the logs
2.
3.
    

Actual Results:  hwbrowser ran

Expected Results:  none of the messages should happen.

Additional info:
Comment 1 Nils Philippsen 2005-03-10 05:21:29 EST
Should be fixed in hwbrowser-0.20-0.fc3.1 which should hit updates-testing
shortly, please report here if the problem is indeed fixed with that package.
Comment 2 Jason 2005-03-10 15:45:06 EST
Good Job, there are no more DeprecationWarning messages when I run hwbrowser.

Thank you for the update.

Note You need to log in before you can comment on or make changes to this bug.